[SOLVED] New Windows Computer, Freedom Box not working

My Freedom box, a Pioneer bought from Mouser in Nov 2020 was running on my home lan plugged in to my router. I swapped out the windows computer I ran it from and now it isn’t running the way it ought to.

Trying to access is as http://freedombox.local does not work but when I access if using its ip number on my lan, I get "Service Unavailable The server is temporarily unable to service your request due to maintenance downtime or capacity problems. Please try again later.

Apache/2.4.57 (Debian) Server at Port 443"

I am not able to access the FB to see its version number but I set it up about the end of 2020 and don’t think it has been updated since unless it does that automatically.

I have tried resetting it using the reset button, but no improvement.

Any ideas?

Thanks in advance.


Hi Ken,

Do you have SSH access to your FreedomBox? If so, we could check the logs to better understand and resolve the problem.

Hi fefekrzr

Thanks for getting back to me. I can get to an ssh prompt. It seems to accept admin as the login but the password I have is wrong so I can’t get it with ssh. I wonder if the easiest course is to do a fresh install altogether? Not sure where to start with that though.


For a fresh install Id recommend starting with FreedomBox/Hardware/PioneerEdition - Debian Wiki


1 Like

Thanks for that link. I have read it and it has me wondering what my best choice would be. My FreedomBox pioneer seems to be running but the login credentials I have won’t let me login on the main screen or by ssh. There is nothing on the device I need to save and the software on the sd card would be 3 years old now. On the other hand, the process of flashing fresh software seems a bit challenging and the materials seem to discourage going that way. Is there a way of doing a reset, a fresh setup, from the current sd card without flashing updates on to the sdcard?

3 years is a long time. Although technically there are ways to hack your way into your FBX (assuming your disk isnt encrypted), its going to take some effort to upgrade to the current version. Ive been usin FBX for just over a year now and a lot has chaned for the better in this period.

My personal preference would be to re-flash your card with a shiny new OS. It may seem challenging in the beginning but IMHO trying to make use of what you already have will probably need more effort to get up-to-date with no issues. Once you get your new OS flashed, auto updates should work just fine as long as you have your box plugged in and running. The effort will be with the reward : )

Have a look at the video in this link. The video is slightly outdated but the applications required and the steps taken are all the same.

Keep posted if you need anything. Will try to help as best.


Thanks to the support I have found here, my FreedomBox pioneer is updated and running nicely. Flashing the current package to the sd card turned out to be easy. The fresh install went ahead without a hitch. Great stuff, thanks all!


Thats good to hear : )
If its not too much trouble, adding a [SOLVED] to the title of the thread will be helping others with similar problems find their way around.

1 Like