SOLVED: Network setup and Privoxy

I just set up my new FBx based on the Raspberry 4B. It shows a set-up as: Cloud - extern - FBx - intern (Freedombox wlan0) - computer.
a) I do not understand this drawing, thinking about it. My Freedombox is connected to the router (Fritzbox) via Ethernet cable and my computer via WLAN to the Fritzbox. No device is connected directly to the FBx (except the router).

Privoxy says wlan0 is connected as intern. wlan0 of FBx is not used, as it is not configured to connect to my Fritzbox. So I tried to de-activate it and activate “Wired Connection 1”, Ethernet, instead. But now Privoxy says, no connection is available as intern and indeed “networks” does not show it.

b) Does this part “intern” have any importance in the connection.
c) Which would be the correct setting for Privoxy?

There is also “Freedombox WAN, Ethernet” connection visible and of course lo.

On my old box (LIME) it shows “Freedombox WAN, eth0” as “intern” and it is functional (still running on old-stable). There are no other connections available on that device. Thinking about it, I had to delete some connection ages ago in some configuration file to make it work.

When activating WAN on my new box, it is placed as external, not internal as on my old box.

I’ve not had my first cup of coffee yet but I’ll give it a go.

First, internal is supposed to be the connection “internal” to your network. This is not physically feasible with a single-LAN port device like a Pi (barring getting some USB dongle) as you would your average router (which would have one WAN port and a number of LAN ports; the former is external and the later internal).

In the absence of two ports to rig this way, then you’d only have an internal since there is some other device sitting between the FB and the internet performing router, firewall, and other security functions. This device will need port pass through for any services you want available outside your local network.

Thus, you see in the drawing there is no external network interface assignment under external (see my screen cap below)

This is section “11.1.1. Single ethernet interface” in the manual (

Privoxy, according to that same manual, is supposed to be on internal networks only.

If you are running from a pi, you need only an internal network and all your services will run there.

Thanks for the link.

This is the connection I have now, which does not work with Privoxy:

The initial configuration was like in this graph, just that no external device was listed.

The setup which I have on my old hardware was exactly like in the manual and it worked

How do I get there from where I am now?

I’m still on Debian 11 (dodging the Bookworm upgrade for the moment) so I only have Wired Connections. But I got half a cup of coffee in me so I’m seeing a bit clearer.

1- What does the self-diagnostics say in Privoxy?
2- Is its check box in firewall on?
3- What does eth0 connection page show? What is it set as?

I am acutally not using WLAN from the FBx, it is even not configured; it was chosen by default. I am using WLAN from my router only.

  1. Self diagnostics says PASSED for all except for TCP6
  2. Firewall says: Privoxy - activated; privoxy: 8118/tcp - permitted (only internal)
  3. eth0 appears twice:
    • as WAN, which is now set on “external”
    • as “wired connection 1”, currently turned off

I turned on “wired connection 1”, which turns off “WAN” and no connection is shown under “external”. So same as in the manual except that I have wlan0 as “internal”.

eth0 now says “Firewall zone external”. There is a BIG warning that this is a primary connection and making bad changes is not a good idea.
Should I try setting it to internal?

First, let me ask if you have any unbacked up data in case we wreck it.
If you don’t or (this being a fresh install) you have no data, then let’s try setting eth0 to internal, as this should be the only type of connection you have.

1 Like

This is the result of it, I de-activated wlan0 as I do not use it and it showed up as 2nd internal connection:


It works.

The the entire problem was that the setup chose wlan0 (not used) as internal connection instead of eth0.

I owe you a cup of coffee, thanks.


No prob! Glad it was squared away so easy.

Mmmh, this morning the old network configuration was set again:

  • eth0: deactivated
  • wlan0: set to intern

No updates were installed over night. Interestingly also the tickmark at “upgrade to next stable” was set, which I had removed. Something reverted these settings to default, I will keep an eye on it.

So I activated again eth0 which was still set to intern.

Edit /etc/network/interfaces and comment out the lines for for your Ethernet and wlan interfaces.

Pretty sure I have posted how to do this. Search for /etc/network/interfaces on the forum search, or check the freedom box manual - it is in there.

This will give control of those devices to FreedomBox, which is what you want.

Don’t modify lo interface, though.

The changes are stable now and Privoxy is working. I cannot reproduce why the network was reset before.

Now that you mention, I recall that this was what I did ages ago, I just did not write it down in my own notes. Afaik, The intention of the FBx-project is to offer a system that works out of the box, so that anyone can participate in a decentralized internet. So the network connection must be properly set during set-up. This definitely requires some work.

Yeah, it’s in the doco and if you pay attention very carefully during installation you’ll see something fly by telling you that you may need to do this. I’m sure there is a reason why it’s not done during install - maybe because if you are installing on debian from apt you are probably not the target user - and you’ll probably figure it out eventually if you are a command line install customer.

When you define a network interface in /etc/network/interfaces that’s a static setup which NetworkManager will ignore. When you comment these then NetworkManager can take control of those devices. If /etc/network/interfaces were to be replaced or modified without you being aware that would trigger that change you describe. You’re on the right side of it now, and I expect that it won’t happen frequently.

Sorry, I have to come back to this, now that I finally migrated all applications to the new hardware.
After a restart, the network connections are re-set to the initial, not working, configuration.

The configuration files include:

$sudo cat interfaces
# interfaces(5) file used by ifup(8) and ifdown(8)
# Include files from /etc/network/interfaces.d:
source /etc/network/interfaces.d/*
And there are no files in the subdirectory:
.../etc/network/interfaces.d$ ls -l
insgesamt 0

So no place to comment out anything.

In the docu ( ) I found information about the “single ethernet interface” which sound to be configured automatically.
For Wifi there is this phrase "All Wi-Fi interfaces are configured to be LAN or internal interfaces in shared configuration mode. ". To me it looks like Wifi is also set to internal in the “single ethernet” setup, thus a software bug.

For the moment I will always change network connections manually.