Solved my own MediaWiki reinstall issue thanks to previous posts

Posting here in case others run into a similar problem, and as a small token of thanks to previous posters.

Note: some resources are not linked because I am limited to two as a new user.

How I got myself into a mess
MediaWiki worked perfectly on install from plinth on my pioneer freedombox — well done everyone.

But I was greedy and sought to set up multiple wiki sites hosted on my one machine by following the mediawiki docs on creating wiki families.

In a hurry and ignoring all best practices, I did not create backups and predictably messed up a few things, for example by failing to create a proper database structure before running php /var/lib/mediawiki/maintenance/update.php.

That tanked the perfect installation freedombox had set up for me initially.

How I got out of the mess, thanks to you all
Ultimately a manual reinstall worked, but exactly how to do that cleanly wasn’t so clear at first.

Thanks to:

I was able to figure out what plinth does via actions in setup. This worked:

  1. run the following as root (purge and install were redundant for me, including as reminder)
apt update
apt install sqlite3
echo "delete from plinth_module where name='mediawiki';" | sqlite3 /var/lib/plinth/plinth.sqlite3
apt purge mediawiki
  1. re-create the directory /etc/mediawiki

  2. copy-paste the config files referenced above into /etc/mediawiki, which were created with freedombox install but deleted in the mediawiki purge

  3. reboot and reinstall via plinth UI as usual.

Works beautifully again. Thanks everyone.

1 Like