[Solved] Missing add-ons storage and networking in cockpit

I have a Freedombox running on a headless debian pc on a lan which has a Win11 pro machine and a debian pc. The server is running Debian GNU/Linux 12 (bookworm) and FreedomBox version 24.9. FreedomBox is up to date.

I have set up a samba share for the hard drive on the server and another for a usb hdd plugged in to that box. The share showed up on the debian box and was accessible. Windows took a bit of fiddling to see the shares but it now lets me access them smoothly.

I then added a second usb flash drive, this time ssd. Both are formatted ext4.

In plinth - storage, I added an open share on that drive as well. The share shows up on both pcs on the lan but can not be accessed. Windows say I don’t have permission. Files on the debian box offers to let me sign on to the share and I take the no authentication option but it won’t go further.

In Plinth | Storage, it says " Advanced storage operations such as disk partitioning and RAID management are provided by the [Cockpit](https://[my server ip number]/_cockpit/storage) app."

However in Cockpit the screen I get does not show Storage. It also doesn’t list Network as an option.

My hunch is that permissions are an issue on the share problem but I am not sure where to go without the cockpit Storage tool.

Any ideas?


(When looking for a solution to a problem you are facing, providing a structured, detailed description of the problem will help others provide a quick response)

Problem Description
(I am tried to enable public registrations in Matrix Synapse app and got an error.)

Steps to Reproduce

  1. (Login to FreedomBox.)
  2. (Go to Matrix Synapse application page.)
  3. (Click on the install button.)
  4. (Select ‘Enable public registrations’ option.)
  5. (Click on ‘Update setup’ button.)

Expected Results
(I expected to see a message confirming the settings were updated.)

Actual results
(I get an error with the following message:)

(Updating configuration failed: error reading configuration file.)

(a screenshot of the screen/webpage when the problem was shown)


  • FreedomBox version: (from Help → About page)
  • Hardware: (name of single board computer or server hardware with architecture)
  • How did you install FreedomBox?: (‘bought pre-installed hardware’ or ‘apt install freedombox’ or ‘downloading testing images from https://freedombox.org’ or ‘using a cloud image’)

hi @KenW

its seems you have 2 different issues here. they may or may not be related. in short,

  • smb share not accessible
  • cockpit not showing “storage” and “networking”

im more interested in the second. how do you normally access plinth from the internet? can you try “your_domain.com/_cockpit/system” (changing your_domain.com with the actual domain and not your ip).

please also see Troubleshooting under FreedomBox

I have not tried to access it from outside my local lan. In a browser if I go to https://[fbox-name.domain-name] it times out.

If I go to https://[fbox-name].local I get the Plinth login screen. ip number works too.

in a normal install, you should see the storage and networking tabs.
could you sudo apt update then apt list cockpit-storaged ?

Here is the result:

ken@fbox:~$ su -
root@fbox:~# apt-get update
Hit:1 Index of /debian bookworm-backports InRelease
Hit:2 Index of /debian bookworm InRelease
Hit:3 Index of /debian-security bookworm-security InRelease
Hit:4 Index of /debian bookworm-updates InRelease
Reading package lists… Done
root@fbox:~# apt list cockpit-storaged
Listing… Done
cockpit-storaged/stable-security 287.1-0+deb12u2 all
N: There is 1 additional version. Please use the ‘-a’ switch to see it
root@fbox:~# apt list cockpit-storaged -a
Listing… Done
cockpit-storaged/stable-backports 311-1~bpo12+1 all
cockpit-storaged/stable-security 287.1-0+deb12u2 all
cockpit-storaged/stable 287-1 all

it seems the storage addon is not installed? really wonder how that came to be…
try sudo apt install cockpit-storaged and then logon to cockpit and see if the storage tab appears.

p.s. I would avoid using su - in general.

root@fbox:~# sudo apt install cockpit-storaged
Reading package lists… Done
Building dependency tree… Done
Reading state information… Done
Suggested packages:
The following NEW packages will be installed:
0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
Need to get 699 kB of archives.
After this operation, 735 kB of additional disk space will be used.
Get:1 Index of /debian-security bookworm-security/main amd64 cockpit-storaged all 287.1-0+deb12u2 [699 kB]
Fetched 699 kB in 0s (3,492 kB/s)
Selecting previously unselected package cockpit-storaged.
(Reading database … 186980 files and directories currently installed.)
Preparing to unpack …/cockpit-storaged_287.1-0+deb12u2_all.deb …
Unpacking cockpit-storaged (287.1-0+deb12u2) …
Setting up cockpit-storaged (287.1-0+deb12u2) …
Scanning processes…

Now Storage appears in Cockpit. Will explore that. Is there something similar that would add the Network selection in Cockpit?

yes there is. try sudo apt install cockpit-networkmanager

Oh my, such magic! Thanks. That will be a big help.

I wonder what I might have done to deselect those packages.

yes, i’d look into that. with a normal fbx installation, the user is not asked if they require these packages or not. they’re installed by default.

from here im guessing you can format and mount your additional storage for use with fbx.

I uninstalled the Samba app and reinstalled it and now the new share that was inaccessible works. Thanks for your help!

1 Like

Thats good to hear.
Would it be ok if you changed the subject to “missing add-ons storage and networking in cockpit”
i believe the issue was hardly related to smb so it might be better for others to find their way.

1 Like