[Solved] MiniDLNA is not starting


I am new to Freedombox and facing problems to set up MiniDLNA.

When I want to open MiniDLNA in the Apps, then I receive following message:
Not Found
The requested URL was not found on this server.

But I should be able to open a web page like it says in the information of the app:
After installation a web page becomes available on https:///_minidlna. It includes information for how many files the server is detecting, how many connections exist etc. This is very useful if plugging external disks with media to check if the new media files are detected properly. If that is not happening, disabling and enabling the server will fix it.

I did install the software several times and did all the updates, but the problem didn’t disappear. And the diagnoses do say, that everything works fine, all the buttons are green.

The Freedombox ist configured as intern on the network port end0.

Freedombox Pioneer Olimex A20-OLinuXino-LIME2

Debian GNU/Linux 12 (bookworm) and FreedomBox Version 24.8. FreedomBox runs the newest version.

Everything works proper (all the buttons are green)

I don’t know what I should do. Does anybody have an idea?

Thanks for help!


Hi @David

The App in the Plinth interface will give you that, it’s normal, not to worry.

If want to access your MiniDLNA web interface;

  • find your FBX local ip address (call it 192.168.a.b for example sake here)
  • in you local network, go to your browser and in the address bar point to http://192.168.a.b:8200

This should show you the miniDLNA interface, number of files in its media library and the clients connected.

Good Luck.


Wow! Thank you! That solved my problem :slight_smile:

1 Like

I submitted salsa issue for this.

@David I think you are supposed to see something like this except that the MiniDLNA button is giving the wrong address (also for me):

If you type in the link yourself it would be https://yourFB.freedombox.rocks/plinth/?selected=shortcut-minidlna

1 Like

Hello. I saw you opened an issue and, for context, I wanted to share the opened issue in the upstream project, in case you’d like to include it in your issue opened in the FreedomBox project. I don’t believe this is a FreedomBox problem.


Credit to @Peterc who shared this with me in another thread a while back.