[SOLVED] Login prompt but no web connection

#1

I received my new Pioneer FreedomBox. It’s powered on (red power light) and plugged into the router (amber and green lights). http://freedombox/ and http://freedombox.local/ do not respond. HDMI works, and keyboard works. I have a ‘freedombox login:’ prompt, but don’t know the root password (as I haven’t ever logged in before).

Using nmap, I determined that the FreedomBox’s IP is 192.168.0.102, but http://192.168.0.102/ does not respond in the browser.

I believe this stems from my powering on before attaching the ethernet cable.

#2

You can try unplugging the battery, leaving it sit for at least a minute, then start with the instructions in order. I ran into a similar issue. When it’s setup, then you can power down and attach the battery. Good luck!

#3

@cniqoot Thanks for the suggestion, but it didn’t work. Still have the same problem - root login prompt (of course this is no good as there is no root login access), and no web access.

#4

It takes a few minutes to complete the initial setup process. You should leave it on for 5 to 10 minutes for the first boot.

I believe this stems from my powering on before attaching the ethernet cable.

I was able to boot FreedomBox devices without plugging in the ethernet cable.

Note that https://freedombox.local only works if you’re on Unix-based systems, not Windows.

#5

FreedomBox’s interface is NOT accessible via the HDMI port. It is only accessible via a web interface. So there is no need to plug your FreedomBox into a monitor or keyboard.

I suspect that you might have some issues with your home router’s local network. Here are two areas to look at:

Confirming the local IP address:

Go to your router’s web interface and look at the device map. The device map should list all the devices connected to your router (via Wi-Fi or ethernet), including your FreedomBox. Does your router recognize the device as a “freedombox”? The router should identify its name as “freedombox.” Please find the local IP address of your FreedomBox from within your router’s device map and enter that local IP address into your browser.

Another way to find the local IP address of your FreedomBox:
If you have an Android device, please download the FreedomBox app. You can use it to find the IP address of the FreedomBox on your local network. Just make sure your Android device is connected via wi-fi to the same local network as your FreedomBox (i.e. to your router’s wi-fi connection).

Making sure you are connected to the same router as your FreedomBox:

Is the computer you are using connected to the same router as your FreedomBox, or are your FreedomBox and computer connected to different routers? For example, some homes have both a modem and a router. If your FreedomBox is connected to your modem but your computer is connected to your router, then your computer might not be able to reach the FreedomBox. In this case, you’d either have to connect the computer to the modem or connect the FreedomBox to the router.

Your client device (i.e. the laptop or desktop you were using to access the web interface) should be consistently connected to the wi-fi provided by the same router which your FreedomBox is plugged into.

If your FreedomBox is plugged into your router, and your laptop is getting its wi-fi connection from some other source, then the laptop is not on the same local network as the FreedomBox and therefor won’t be able to access it.

See if these two points help you and get back to us. Best of luck, and thanks for your patience.

#6

I tried booting it up without the ethernet cable, and list it sit for 10 minutes. Then when I tried the IP in the browser, the FreedomBox setup screen came up. I guess it was all just my impatience.

#7

Great, I am glad to hear that you figured out the problem. Thanks for the update. I will make your issue as [SOLVED] in the title.

Let us know if you have any other questions in the future!