[Solved] Kernel Update Notice on Raspbian

Problem Description
Kernel Update Notice appears every time I run apt update.
Steps to Reproduce

  1. Login to FreedomBox via SSH
  2. Run apt update && apt upgrade && apt autoremove -y && apt autoclean -y
  3. Apt runs update & upgrade, then gives the following message:
  4. Pending kernel upgrade Newer kernel available The currently running kernel version is 5.4.79-v7+ which is not the expected kernel version 5.4.83-v8+. Restarting the system to load the new kernel will not be handled automatically, so you should consider rebooting.
  5. Run shutdown --reboot now

Expected Results
I expect system to update Kernel to version 5.4.83-v8+.

Actual results
Upon next system update & upgrade, the message appears again.

  • FreedomBox version: FreedomBox version 20.21.
  • Hardware: Raspberry Pi Version 3B+
  • How did you install FreedomBox?: Installed Raspbian, then installed freedombox from Raspian Repo using apt.

On Raspbian, the kernel is not the typical Debian kernel. It is provided by Raspbian. A script to upgrade the kernel is provided by the Raspberry Pi Foundation. If that same script is used in Raspbian, you may have to run it manually to upgrade the kernel. Please check Raspbian documentation for it.

I too run a PI (I have a pi4, but also installed by installing raspbian, then sudo apt install freedombox), and I too get this annoying and somewhat concerning message.

DO NOT UPDATE THE KERNEL!!!1 It causes issues elsewhere on the system. At the minimum the backup app does not work. This is not a “freedombox problem” people running other software on PIs report problems too. When an ecosystem has been one way (32bit) for so long, and nobody ever thought it would change, there will no doubt be problems when it changes…

For general info, if you want to update the kernel you can force it by editing the /boot/config.txt file. Mine looks like this:

#Force “speshul” Kernel
#This didn’t work

(my arm_64bit=1 line is commented out, because I like computers that work. I left it in the config because someday I will experiment with it again.)

@sunil & @strictdual,

Thanks for the reply on this post, I’m glad I didn’t mess with it! @strictdual, I appreciate the pains you went through to find this out and share this with us.

I also want to add that one shouldn’t face issues with kernel upgrade when using FreedomBox images for Raspberry Pi since these images contain vanilla Debian kernel updated usual regular apt/unattended-upgrades. The latest images, however, require SD card for booting and additionally USB for actual storage.

Thanks for the additional info! :slight_smile: