[SOLVED] Installing u-boot on armv7 image

Hi all,

Some help and pointers so I can proceed where I’m stuck!

I’ve built an image with freedom maker, which I plan to use on a nanopineo and orangepizero boards.
However, the images produces are not bootable because u-boot is not installed with the maker, like armbian does with their build system.

I’ve tried to build u-boot but it’s failing due to dependencies and I don’t want to pursue any more in that direction.
Is there a way I can download u-boot pre-built images for these boards, both which share basically the same CPU?
Or extract the binary stream from an existing nanopineo image and poke it into the new image generated by freedom maker?

And if so, what is the correct way to put (dd?) the u-boot binary bytes into the built images.


Replying to myself and for the benefit of all!

I’ve flashed the image freedombox-bookworm_orange-pi-zero-armhf.img.xz on both of my boards, the nanopineo and the orangepizero and to my surprise, it works on the nanopineo too!
So no need to fumble around with u-boot binaries. I assume this image should work with any H2+/H3 AllWinner CPU boards, as they are basically the same CPU and instruction set of ARM Cortex-A7 architecture
The nanopineo doesn’t have WiFi but the orangepizero does. Also the orangepizero has video output pins and the nanopineo doesn’t. And other minor details.
The only thing that shows under System Information on Cockpit on the nanopineo is that it says "
Xunlong Orange Pi Zero", which is incorrect. And I assume that is because it’s hard coded somewhere in the boot files. But other than that, everything is working just fine!

1 Like