[SOLVED] Increase Roundcube Message Attachment Size Limit

Roundcube is installed with a default maximum attachment size limit of 2M. If anyone is interested in increasing this limit, I wanted to share the steps I took below.

FBX Version:
Debian GNU/Linux 12 (bookworm) and FreedomBox version 24.5

STEP 1: Edit php-fpm with sudo nano /etc/php/8.2/fpm/php.ini
configure the following paramters to 100M

post_max_size = 100M
upload_max_filesize = 100M

STEP 2: Restart php-fpm and apache

sudo systemctl restart php8.2-fpm
sudo systemctl restart apache2

That’s it. Now you should be able to upload attachments upto 75M.

Note: Roundcube attachment size limit value seems to be additionally limited to 75% of $config['max_message_size'] = '100M' in /etc/roundcube/defaults.inc.php. I didn’t need or want to play around with this parameter as I’m not sure of the outcomes that may relate to overall FBX configuration. If anyone feels to increase the value to something higher, feel free to comment this post.