[SOLVED] How to start the initial configuration process

On a partition on an old Sony Vaio I have:

I have followed the wiki.debian.org/FreedomBox/Hardware/Debian instructions and

  1. Install Debian 10.0 (Buster), or Unstable (Sid) on your hardware
    2, Update your package list
  2. Install freedombox package
    and a great deal of info flowed into my working debian browser.
    However I did not get a secret key.
    I don’t know what should happen next. Was there some final instruction that I missed? How do I start the “initial configuration process”? What door do I knock on to begin “During the installation”.

Have you tried accessing http://freedombox.local/?

You can obtain the secret key at /var/lib/plinth/firstboot-wizard-secret.

1 Like

I had not tried but alas my attempt has failed.
AND my request for the secret has met with permission denied.
Double alas.

Do you know the local IP address of the Freedombox? You can find it at your router settings. Or if you are using GNU/Linux, you can use nmap:

$ nmap -p 80 --open -sV (replace the ip/netmask with the one the router uses)


$ nmap -n -sP

From https://wiki.debian.org/FreedomBox/Manual#FreedomBox.2FManual.2FQuickStart.How_to_get_started

Once you have the IP address, you can try that in your browser.

For the secret key, use sudo:

$ sudo less /var/lib/plinth/firstboot-wizard-secret

Hope that helps!

1 Like

Thank you, so far so good. I retrieved the secret key. I’m a point and click man so the necessity of sudo was understood once pointed out.

However, I’m coming up croppers the second half of the problem. I had prepared ahead of time with IP4 and IP6 and tried substituting these in various ways in the formats suggested. My terminal says nmap command not found. I recognize the manual pages you are referring since I have done some due diligence but alas my skills are literary not computerly.

Try the router’s web interface: you should be able to see all of the devices in your local network. Many routers use the IP address for admin access; if that doesn’t work, search online for your specific router.

1 Like

The snail crawls on. I have accessed my router – which I think is very interesting. I live in northern Thailand and my router number was related to other numbers but my local IP starts with 100 and is quite different from all the other IP numbers I[ve been told were related to me.
HOWEVER I still don’t connect to my Freedombox .

Thank you for throwing the bread crumbs.

At the router web interface, do you see a list of devices connected to your network? If yes, do you see your Freedombox in the list?

1 Like

I did just find the list – a humungous list of tablets, phones, and pcs, but no Freedom box. I did plug in an IP address for the pc/Sony Vaio (I think) that led me to

Debian Logo Apache2 Debian Default Page.

I hadn’t really expected to see Freedombox but I am blown away by having access to all the info I saw.
But no cigar.

Oh I got off on a side track to enable nmap. and i installed a new terminal Guake that is WAY better.

Continuing…this sounds interesting, but what it means for me is puzzling

Debian Logo Apache2 Debian Default Page
It works!

This is the default welcome page used to test the correct operation of the Apache2 server after installation on Debian systems. If you can read this page, it means that the Apache HTTP server installed at this site is working properly. You should replace this file (located at /var/www/html/index.html) before continuing to operate your HTTP server.

If you are a normal user of this web site and don’t know what this page is about, this probably means that the site is currently unavailable due to maintenance. If the problem persists, please contact the site’s administrator.

Just a thought: try restarting the Freedombox server. Wait a few minutes for things to get going, and then try the local IP for the Freedombox again.

YES – starting setup!

Things are going smoothly. I’m installing MediaWiki. Many thanks and appreciation. I’ll try to pass on the favor some time.

1 Like

Great, perhaps you can change the post’s title and add [solved]! The wonderful thing about communities like these is everyone contributes when they can :slight_smile: Have fun with your Freedombox.

1 Like

Oh. Duh. I guess you helped me with that. Thanks again.

I didn’t do anything, one of the site admins must have.