[SOLVED] How do I restore FreedomBox?

Good afternoon, Freedombox backed up media-wiki to a usb flash drive. After reinstalling, I want to restore media-wiki from the backup. Here is the content of the flash drive (see screenshot), which file do I need to load to restore?

Good afternoon,
You should connect the flash drive into your FreedomBox, then navigate to “System” >> “Backups” >> “Add Backup Location”.
There you select the drive and submit the same encryption passphrase that you entered when creating the backup on your flash drive. After you click on “Create Repository” the backup(s) should be listed under “Existing Backups”.

Yes, but when I do that, I get this (see screenshot).

What if you set the Encryption type to “None”?


If you know how to use the command line, try cooying the backup into the internal storage and backing it up from there.

I had the same problem. It wouldn’t work with my backup stick, so I downloaded the last backup tar from within the backup app and uploaded it to the new installation.

The backup is done without encryption, the encryption option is set - no.

okay, do you know how to copy the files onto the box or need some help with it?

I know how to do it. Thank you!

1 Like

Backup has no documentation on how to restore – because there is no way in the GUI to do it?!?!!??!!?!?!!? This is intergalactic.
Any storage containing FreedomBox backups are officially USELESS because there is no way to restore them. Without warning. You’ll learn in time. Unless of course the average skilled user just connects via SSH to somehow copy borg backup folders to the correct place. :exploding_head:

This needs fixing if the project wants to be taken serious. I think I will somehow manage to get this done in about half an hour or so - but this has to be the ultimate deal-breaker for anybody trusting FreedomBox with their data.

Just to reiterate:
I did the same things as OP and got the same error as OP.

  1. backup to a USB stick
  2. reinstall freedombox
  3. restore backups from USB stick → not possible.

…those steps do not strike me as a rare edge-case. :tipping_hand_man:

(P.S.: copying the files took me way longer and without help from Lars from matrix chat I would have been lost completely)

1 Like

I agree that the backup is lacking documentation for restore. I see this as a critical issue.

I don’t have time now to read the details of what you are doing and what happens. In case it helps, here is the link to the post where I described how I restored a remote backup: Cannot add remote backup for restore

Fix for this has been merged and will be available in the next release. Thanks to @nbenedek. backup: fix bug in adding backup location (!2421) · Merge requests · FreedomBox / FreedomBox · GitLab