[SOLVED] Help after accidentally disabling internet connectivity via ethernet port

Debian Buster / Freedombox was up-to-date (as of 2019-11-11)

[Edited to focus on select issues.]

To turn my Olimex Pioneer Edition Freedombox into a router I bought a 4-port usb-to-ethernet adapter/switch. In an attempt to set it up, I managed to disable the connection to my Freedombox.

What I did:

  • System > Networks > +Add Connection

  • Connection type: Ethernet

  • Connection name: FreedomBox LAN

  • Physical interface: [the onboard ethernet port]

  • Firewall zone: Internal

  • IPv4 Addressing Method: Shared

  • Address:

  • Edit Connection

  • Activate

[Reference: https://en.wikibooks.org/wiki/FreedomBox_for_Communities/Network_Configuration]

I imagine my newbie mistake was to select “Ethernet” as the connection type and then “IPv4 Addressing Method: Shared”, effectively disabling the ethernet internet connectivity to the Freedombox server.

One comment:

  • If possible, perhaps it is a good idea to render it impossible to share the ethernet connection via the GUI if only one ethernet port is available.

One question:

  • How can I connect to the Freedombox server?

Thank you for any help!

I was able to solve the connection problem, but only temporarily.

I connected the Freedombox to a monitor via the HDMI port, logged in, and deleted all connections using nmtui in the terminal. I rebooted but the Freedombox remained without an internet connection.

Once logged back in, I ran in the terminal

$ sudo dhclient etho0 -v

and a connection was established. I can now log in to Plinth via the internet. However, the connection is gone again if I reboot.

Also, when connecting via ssh I get the warning that the “remote host identification has changed”.

Any suggestions for how to fix this connectivity problem permanently?

Edited to add: In the Networks interface in Plinth I am also receiving this warning:

This interface is not maintained by FreedomBox. Its security status is unknown to FreedomBox. Many FreedomBox services may not be available on this interface. It is recommended that you deactivate or delete this connection and re-configure it.

And the Firewall zone is set to “none”.

I fixed the issue by logging into the Freedombox using the temporary connection and doing the following:

  • Go to System > Networks > +Add Connection

  • Connection type: Ethernet

  • Connection name: FreedomBox WAN

  • Physical interface: [the onboard ethernet port]

  • Firewall zone: External

  • IPv4/IPv6 Addressing Method: Automatic (DHCP)/Automatic

  • Edit Connection

  • Activate

The connection in the Networks interface obtained with dhclient and the accommodating warning (see reply above) have now disappeared. This solution likely could have been done directly with nmtui in the console.

1 Like

This may be coming late but another way to solve this issue is to access the files of the troubled system (mount SD card or boot from recovery disk) and then edit the files in /etc/NetworkManager/system-connections/FreedomBox\ WAN.nmconnection to something like this:

id=FreedomBox WAN
uuid=<leave the UUID number as is>
interface-name=enp0s3 (whatever the interface is)





Note that removing the file also will work because network manager will create a new file to simply to automatic network configuration using DHCP.