[SOLVED] Gobby text editor is not connecting to the server

On Matrix I installed the Gobby Server without any problems. On my MX Linux (distro) PC I installed the desktop Gobby text editor.

I really tried everything but the editor is not connecting to the server.

Local IP lan is placed in the DMZ and TCP port 6523 is forwarded in the router.

Hello @eca56,

I’m sorry to hear about the difficulties you’re encountering with setting up Gobby. To help you more effectively, could you please provide additional details about the problem and your configuration?

Regarding your mention of installing the Gobby Server:

I’m a bit confused about this statement. To my knowledge, Gobby isn’t directly related to Element/Matrix or the Matrix Synapse server, so I’m curious about how you’ve integrated Gobby with your Matrix setup. Could you clarify the steps you took to install the Gobby server?

Concerning your network setup:

Port forwarding is an effective strategy if you’re aiming to access your FreedomBox’s Gobby server from outside your local network (via your domain name or external IP address). This method alone should enable external access to your server, streamlining connections without the need for additional network adjustments for local access.

For connecting to the Gobby server within your local network, port forwarding typically isn’t necessary. Local connections can directly communicate on the LAN, bypassing the router’s NAT (Network Address Translation) and firewall configurations.

It’s worth mentioning that placing your FreedomBox in the DMZ of your router and configuring port forwarding concurrently might be redundant. Since the FreedomBox is designed with security in mind, placing it in the DMZ is manageable and might be simpler if you are not used to doing port forwarding.

If you’re aiming for external access and encounter issues, additional factors might be at play. Could you provide more details about any specific errors or challenges you’re facing when trying to connect?

Any additional context you can provide will greatly assist everyone in understanding and addressing your issue more effectively.

Looking forward to your response!

1 Like

Gobby activated in FreedomBox and TCP port forwarding in router set. No problem and errors.

Installed the Gobby text editor on my MX Linux computer but if I want to connect to the server it fails.


Verbinding is geweigerd = connection refused

Does it still fail if you connect to the Gobby server when using the local IP address of your FreedomBox?

Yes! it connects without any problem when I use
I only get the popup that the connection is insecure and the question if I want to continue.

So maybe Pagekite is creating the connection problem.

Based on our discussion in your other post, it appears that Pagekite might indeed be the source of the connection challenges you’re encountering. It seems like Pagekite typically supports a predefined set of ports, primarily catering to web services and SSH by default. If Gobby isn’t using one of these supported ports, this could explain the connectivity issues.

I’m not sure but, while it might be possible to configure Gobby to operate through one of Pagekite’s supported ports, I still believe the domain name solution I suggested in your other post would be more suitable and seamless for your specific needs. This approach could bypass the limitations you’re facing with Pagekite and streamline your Gobby server’s accessibility.


This was actually not easy. Because I was using for my Dahua server NO-IP you gave me the advice to use NO-IP also for the FreedomBox.

So I did and stopped with GnuDIP and Pagekite.
For the FreedomBox I started a totally new domain with NO-IP but it really took me a long time to figure out how to configure it within the FreedomBox.

If someone else wants to use NO-IP, let me know and I can explain how to do it.

The problem I did not get to see my WAN-IP and it was impossible to get SSL activated.
It was really driving me nuts!

The Dahua server is using port 8080 and for the FreedomBox I was going for 80.

All this was caused by the fact that a TP-Link router is using 80 as default for remote management.
I do not use that anyway so I had to change that to something like 50000+.

Added a 80 port forwarding to local FreedomBox Lan.

The default port 80 setting in the router was causing all the problems.

And the Gobby connection is working now over the WAN.

Next step is now to get my Matrix issues resolved.

Thanks for all the tips and suggestions.

How to change?

Gobby text editor is not connecting to the server


[SOLVED] Gobby text editor is not connecting to the server


I noticed from your updates there might have been some mix-ups or parts of my previous posts that got overlooked. It’s easy to miss a detail or two, especially when you’re learning and managing many things at once.

About adding a new domain with NO-IP, originally, we were aiming to simplify by using the domain that you already had set up for your Dahua server, as I was assuming it was in the same network as your FreedomBox. Also, you said you had DDNS already set up, so there was no need to duplicate this for your FreedomBox.

Since you’ve gone ahead with a new domain, you need to add that domain to your FreedomBox’s configuration, from your FreedomBox’s web interface (Plinth). Once you’ve done that, you should look into setting up, from your FreedomBox’s web interface (Plinth), DDNS and Let’s Encrypt. I reckon the latter is necessary for Matrix.

I still don’t understand the port 80 situation of your router’s web interface. It shouldn’t interfere. The router’s web interface should only be accessed locally, preferably by connecting physically to your router. The router’s web interface should not be accessible from the internet.

If something isn’t clear or doesn’t work as expected, it might be worth revisiting the instructions or our previous suggestions. Sometimes, a second look can help spot what was missed the first time.

Also, having just enough knowledge can sometimes lead to making things more complicated than they need to be. It’s all part of the learning curve, and each mistake is a step towards getting better at this.

Please don’t take this the wrong way, as I’m trying to help. If you need help setting something up, I’d recommend asking first before making any changes. Sometimes things are simpler than they seem.

All the best!

Unfortunately, you can’t yet. I lost my “Regular” badge, so I can’t either. If I get it back, I’ll add the [SOLVED] to your topic’s title.

The router has port 80 set as default for managing over WAN (TP-Link).
If you want to use the port for something else like FreedomBox you have to change that port setting. If you do not do this it will always go back to 80 for remote management over the WAN.

It is really stupid that TP-Link is setting 80 as default for remote management.
It is an old router so probably they are not doing this anymore.

In my account with NO-IP I can setup 5 domains so I thought why not make a separate one for the FreedomBox.

I am not using Pagekite and GnuDIP anymore only NO-IP.


With this router is remote management possible over WAN. Its really stupid.

Edit: Fixed typo.

Wow. Ok. Personally, I would disable this Remote Access option, unless you really need it for some reason. I don’t think it is worth the risk.

Ok. So you did that intentionally and it’s ok. I thought that you had misunderstood my replies.

Have you already configured your domain name in your FreedomBox’s web interface?


And your DDNS and Let’s Encrypt?

The NO-IP really works very well but I had to figure out how to get it configured within FreedomBox.
Dynamic DNS / Let’s encrypt and Name services are all set on the new domain and I have no errors.

I had some problems with Syncthing to get the previous domain wiped and the same with Matrix.
But it is really no big deal, this is a learning proces and if I remove and install the apps I think the problem is solved.

Gobby works now also over the WAN.
Last week when I still had this setup with Pagekite I did a couple of pings to find out the IP-Address and the location. I travelled all around the world.

If I ping the domain now it is showing the IP from my ISP.

I really appreciate the time you are investing in helping me.

I know for my self that I learn from the mistakes and I also document everything for future setups because you forget how you did it.

1 Like

I saw that FreedomBox also supports WireGuard. Today I installed the VPN service from MULLVAD from Sweden on 2 smartphones and also on my MX Linux PC.
I know this has nothing to do with this thread but I am so impressed with the performance and how easy it was to get it running. The speed starting and switching locations is unbelieveble (2 sec.)