( Solved ) Freedombox install on a vps fails at - update-initramfs:

Hello All,

Problem Description

I am trying to install freedombox on a remote vps and up to now it with no success. I have installed screen to run the apt freedombox install session in. Before I try to install freedombox, I have edited the interfaces file, so it only as shown below in it:

# The loopback network interface
auto lo
iface lo inet loopback

The line below is all so in the interfaces file. I have tried to install with the line source, # out and not # out but with no luck.

source /etc/network/interfaces.d/*

There is a file in the interfaces.d directory, named: 50-cloud-init

# This file is generated from information provided by the datasource.  Changes
# to it will not persist across an instance reboot.  To disable cloud-init's
# network configuration capabilities, write a file
# /etc/cloud/cloud.cfg.d/99-disable-network-config.cfg with the following:
# network: {config: disabled}
auto lo
iface lo inet loopback
    dns-nameservers 2001:19f0:300:1704::6

auto enp1s0
iface enp1s0 inet dhcp

# control-alias enp1s0
iface enp1s0 inet6 auto

Once the freedombox install gets to update-initramfs: part, which is 97% done, The ssh connection is lost and what left in the terminal is shown below:

Processing triggers for mailcap (3.69) ...
Processing triggers for initramfs-tools (0.140) ...
update-initramfs: Generating /boot/initrd.img-5.10.0-16-amd64

I leave the freedombox install for a while thinking it will get passed the update-initramfs: point. Then I will reboot the vps from my online account. The vps dose reboot, it say in my online account it running but there no ssh connection to the vps and no ping.

So regards to all and any pointers ? peter


  • Debian GNU/Linux 11 (bullseye) and FreedomBox version 22.15
  • Hardware*: (on a remote vps)
  • How did you install FreedomBox?*: (DEBIAN_FRONTEND=noninteractive apt install freedombox)

Mine is installed atop Debian 11- I followed these instructions.


Mine is running as a VM on a server so somewhat similar.

Hello again,

From what I been reading, that the network is being setup by cloud-init, this is the way cloud images set up their network ? A idea may be is to disable cloud-init then edit the interfaces file so it look like below:

# The loopback network interface
auto lo
iface lo inet loopback

Then install freedombox and reboot and hope NetworkManager takes over ? wish full thinking !

Regards: peter

I rarely muck around in the interfaces files so I’ll have to read up a bit.
I get the feeling the lack of response isn’t due to network issues but something hung up and it stops answering.
Does the provider offer a web-based shell interface?

Hello @timmy

In the web account there is the option of vnc. I have not yet set that up, I will be looking into it ! After I install freedombox and it hangs, the vps is still seen as running but there is no ssh connection. I reboot the vps and there is no ssh connection but the vps again is seen as running.

I have edit the interfaces file as needed and made the file shown below to disable config-init from enabling the network setup so that NetworkManager can take over !
nano /etc/cloud/cloud.cfg.d/99-disable-network-config.cfg
in it is:
network: {config: disabled}
So up to now no luck, vnc the next task.

Regards: peter

hmmm. Good luck I suppose.
Do you have a spare machine at home you could spool up proxmox or some other virtualization software and mimic this build out just to ensure your steps work correctly away from this VPS host?

If your steps work fine, then maybe you can reach out to the provider and engage their tech support on the issue.

Hello @timmy

I can see the reason with setting up a vps at home to see if I could see why the freedombox install hangs at 97%.

I just got vnc working to the vps, with fluxbox as the desktop. My online account as a novnc web page connection. If I get the online web vnc working I would be able to get access to the vps. So I could see why the freedombox install as stalled. From the apt logs ? If I reboot the vps, when it comes back up, I can not ssh to it but my online account say it up and running. That why vnc from my web account could be handy ?

I will do a standard install of freedombox on a machine at home to see if there a reason for the install to hang ?

Regards: peter

ps, I have done a freedombox install on standard debian install and all ok, go pass update-initramfs: with no problems.

I’m guessing you need to be logged in as the SU on your VPS; the one who ran the FBox install.

FBox is ez to Admin if you’re on the local network it resides on.

Additionally, if you completed the full install process, you created an Admin Accout, within your base VPS install.

If you have ‘inside’ / ‘LAN’ access to your FBox, you should be able to use your original root accout, +/or the Admin Acct. you created during install.

You need to have LAN type access to setup FBox for WAN Admin access.

So, login to your VPS as the SU and make the appropriate changes after reading FBox Docs that explain how to, and the potential problems of, SSH from the ‘net’ to your server.


I hope the VNC works but if the system hangs, I don’t know what might happen to the process running the VNC server.

Lack of SSH on reboot sounds like something is borked when it goes to start services. Like systemd is in a bad state.

Previous installs might have passed. But since FB is a project-in-development, there can be breaking updates from patch to patch.
ie an update or two ago that bumped up the matrix-synapse service version but a dependency wasn’t available in repo. So matrix broke hard.

Does your web interface you launch/reboot the VPS from show current IP address and such? Making sure you are not drawing a new IP or something stupid that’s easy to overlook.

Hello @timmy

When the vps comes back up after a reboot. From the online vps account it say it got a ip address and it is running. But there is no access by ssh.

Thanks for pointing out that it may be because of a software update.

Regards: peter

ps, I just # out the apt source line for backport and apt update and then install freedombox. but same again. it could have been !

Hello All,

And good news, I found the problem with the vps and hanging with the freedombox install at %97. When the vps is installed it get setup with ufw as it fire wall.

BINGO - **ufw disable**

Install freedombox and it up and running.

Big thanks to all, regards: peter


After seeing your post, I remember that I ran into this issue before, and added a note about it here: FreedomBox/Cloud - Debian Wiki
Perhaps the documentation can be improved though (copy it to FreedomBox/Hardware/Debian - Debian Wiki ?)

Hello @jvalleroy

Thanks. Regards: peter

Glad to hear it got sorted out.