[SOLVED] Freedombox day 1: nothing's working


**My freedombox is plugged into my home router.
**I ordered my kit last week (oct 29 2020) from olimex and received it shortly after. I plugged it in today for the first time.
**My box is running Debian GNU/Linux 10 (buster) and FreedomBox version 19.2. The ‘?’-page indicates that there is a new version available. I ran the manual update twice from the system/update page, and though I can’t see anything updating, the freedombox won’t re-boot because > ‘Currently an installation or upgrade is running.’

First impressions :

*tinyRSS works great.
*Tor network works great.
*Searx works. For every other search, the ‘General’ tab of the page will return empty, though.
*MatrixSynapse could never install - packages were broken. Too bad: this app was my main motivation for diving into the box.
*deluge installed and ran. I couldn’t get it to connect to the web, though.
*Radicale installed but never opened - the server just gives me 503 error.
*privoxy installed and ran, though it blocked every page I tried to visit with it. Configuration page showed the server as offline, and I couldn’t load the user manual page.
*Certificate never got assigned. I tried several domain names, but the processed just crashed on every attempt with errors the likes of:
"Failed to obtain certificate for domain perken.freedombox.fr: Saving debug log to /var/log/letsencrypt/letsencrypt.log Plugins selected: Authenticator webroot, Installer None Obtaining a new certificate Performing the following challenges: http-01 challenge for perken.freedombox.fr Using the webroot path /var/www/html for all unmatched domains. Waiting for verification... Cleaning up challenges Failed authorization procedure. perken.freedombox.fr (http-01): urn:ietf:params:acme:error:dns :: DNS problem: NXDOMAIN looking up A for perken.freedombox.fr - check that a DNS record exists for this domain"
*After trying to setup the certificate for the third time, the box itself crashed. After turning it off and on again a couple of times, the box stopped responding. Currently https://freedombox.local/ doesn’t open and I’m locked out.

Is there anything I can do at this point ?

I’d maybe wait a bit for more knowledgeable users to chime in, but if you don’t have much saved on it, I’d just reinstall.

The biggest thing I would advise after that is to be patient with the little server.

It’s not clear from your post if the box finished upgrading. I suspect a fresh install will use a more up to date version (were on 20.16, and 20.17 is due soon) but in either case I would let it sit as long as it wants to do that first. Just create the admin account, and push the manual update button, but let it do its thing before you start installing stuff. This can take a bit of time, but let it run.

Hopefully that will solve your Matrix and other issues automatically. The recent releases work quite reliably, just give it its time.

Your letsencrypt message sounds like your ddns is not set up right. It sounds like there is an issue with how its entered on the DDNS page, or how its set up on the hosting site. I would not worry about this until the box is running an up to date version of the software.

My usual new freedombox procedure is:

  1. Wake it up & go to freedombox.local or the proper local-IP address.
  2. create an admin account
  3. push the manual upgrade button
  4. let it upgrade
  5. install Tor
  6. activate the DDNS
  7. get a letsencrypt certificate
  8. then install other stuff
1 Like

Hey, thanks very much for this helpful reply !

I managed to enter the box through its IP adress (thanks for the pointer) and did the following:

  1. Updated the box’s version to 20.16
  2. Tried to update Tor’s app, which doesn’t work after several attempts
  3. De-activated previouly-installed apps when possible.
  4. Ran diagnostics, which returned a failed test containing only: ('tor', '', '')
  5. Tried to deactivate automatic updates - from there nothing worked anymore.
  6. Tried reporting the bug on debian’s issue tracker, but apparently I can’t sign up because I use a gmail account.

From there, access to the freedombox has been erratic at best. I’ll get access for a minut followed by 5 minuts of “Service Unavailable”. Is there anything I can do from here ?

My first vote is still just starting over by over-writing the microSD card.

But, to try to get it working - can you access the Freedombox using ssh? The username is the Admin account name, and password is the admin password. If that works and stays connected for more than a few minutes I would try to update/upgrade everything using:

sudo apt update && sudo apt upgrade

This may upgrade everything, but pauses briefly to confirm that you really want to do it. Check the output for obvious error messages, and then hit y and pray… It may also just spit out a variety of error messages. This one is super-common, especially if the machine looses power or is unplugged in the middle of an update.

E: dpkg was interrupted, you must manually run ‘sudo dpkg --configure -a’ to correct the problem."

If it says that or something like it run what it says to run. Otherwise, report back with the errors.

If there are no errors, I’m stumped, but there are hopefully more knowledgeable people around to help.

I followed all your suggestions and it worked great : I triggered the update through SSH and everything went smoothly from there. Tor, DDNS and certificates were setup easily.

I now have the Matrix synapse up and running, and am in the process of trying it out with my family. Thank you very much, strictdual, for giving me such precious help and advice !

I look forward to all the privacy-conscious adventures to happen on my freedombox !



If everything’s ok now, would you please update this thread’s title with a leading [SOLVED] mark?

Thanks in advanced.

I’m sorry for being such a noob, but I can’t seem to find where the option to modify the title is. Can you point me to it ?

1 Like

Don’t be ashamed. I don’t know either. :thinking:
In fact I didn’t even know I didn’t know it, until I unsuccessfully searched for it.
I know it is possible though, since others have recently done so on my request.

I think it may be a shame for the forum software to disable fixing or updating things in older messages and topics.