[SOLVED] "Error installing application" Unmet dependencies

Good morning.

Problem Description

  1. I click to install OpenVPN: installation doesn’t go beyong the initial “installing openvpn, easy-rsa”. It yields the following error: “Error installing application: Error during installation E: Unmet dependencies. Try ‘apt --fix-broken install’ with no packages (or specify a solution)”.
    I don’t even know how to open a terminal in FreedomBox.

  2. I click to install SearX: installation doesn’t go beyond the initial installing searx, uwsgi, uwsgi-plugin-python3. Yields the same error as problem “1”.

Home Screen warns I have 109.3 MiB free space left. I don’t think this is a problem, but feel free to enlighten me how to expand my space.

I can provide the Diagnostics report if needed.

Information
Running VirtualBox 64-bit img: Debian GNU/Linux 10 - FreedomBox version 19.19, on a VirtualBox within my Intel NUC, which is running Windows 10 Pro. I connect to my Intel NUC through TeamViewer.
Successfully installed MediaWiki, MLDonkey, Tor, and Sharing.
MediaWiki and Tor are running just fine. I haven’t used MLD or Sharing.

I’m a non-technical Windows user who knows how to “sudo apt-update” in Linux, and that’s about it.
I connect to my FreedomBox through Tor.

You need to follow exactly the instructions of the message sudo apt --fix-broken install by either ssh’ing in the box or from cockpit. If that is not successful you might have broken dependencies which are difficult to fix. Did you to run apt install for a package manually?

Thanks. Didn’t know where the terminal was.
After trying the “sudo apt --fix-broken install” I found that there was a lack of enough disk space to perform function, as it required some pending updates.
Upon going through tedious process of expanding a .vdi image, I returned to the terminal and applied all software updates.
After that I found I could install the other software without problems. My OpenVPN setup is running (takes a while to set up), hopefully up and working soon.