[SOLVED] Download Link Error

Hello FB’ers,

Today I tried (5/11/23) to download the latest version of the Pioneer Edition FreedomBox software and got the following error:

Not Found
The requested URL was not found on this server.

Apache/2.4.56 (Debian) Server at ftp.freedombox.org Port 8

Just wanted to inform you there is an issue with the download page (image & signature links do not work).


The problem seems to be with the path in the link to the “Download image” and “Signature” buttons. See image below:

This issue is probably related to one of the points raised in the latest call. One of the participants pointed out that the image available in the website was Debian 11 and that it should be updated so that users who downloaded it wouldn’t have to experience the issues others did when upgrading to Debian 12.

They changed the naming scheme for the files, thus the broken link.

Just wanted to add further context. Thanks for reporting!


We were updating the stable images in discussion with the Olimex team and missed this. It is now fixed. @DachaLife , thank you for reporting. @fefekrzr , thank you for investigating.