[SOLVED] Cannot install any app due to incorrect system time

Problem Description
I was not able to install anything after flashing the testing Debian iso on my Raspberry Pi 4

Steps to Reproduce
1.Flash a new sd card with FB
2.Make a local account
3.Update FreedomBox
4.Try to install anything using the web interface

Expected Results
Install application and services of app
Actual results
Failed install with error message,

Error installing application: Error during installation E: Release file for http://security.debian.org/debian-security/dists/testing-security/InRelease is not valid yet (invalid for another 30d 17h 30min 4s). Updates for this repository will not be applied. E: Release file for http://deb.debian.org/debian/dists/testing/InRelease is not valid yet (invalid for another 30d 23h 16min 36s). Updates for this repository will not be applied. E: Release file for http://deb.debian.org/debian/dists/testing-updates/InRelease is not valid yet (invalid for another 30d 23h 16min 35s). Updates for this repository will not be applied.


You are running Debian GNU/Linux bookworm/sid and FreedomBox version 21.12. FreedomBox is up to date.

Hey y’all, I have not posted in a while (which is a good thing). I have had an SD card fail on me so I re-installed FreedomBox on my Raspberry Pi’s. I was having this issue; I have changed my sources but that ended up making an un-usable OpenVPN install (the interface would not give me the profile, after stitching one together It would not transfer any website data even though it connected.), That is an issue for another day. Is the solution just to update my sources? I know how but I don’t know which ones to add.

1 Like

Sometimes this error message can be caused by an incorrect system time. Have you checked that yet? You can change what time zone your box is set to in the web interface (System/Date & Time).


Oh wow, I have not. I’ll check that this weekend!

The auto timezone function would not work. While the date was correct, the reported time was 00:00:00. I have no clue why. I was able to manually correct it using these two commands.

Sudo date --set 2021-11-29
Sudo date --set 1:50:00

After a reboot, I was able to log into FB and install apps. Thanks for the tip! It helped out a lot.

1 Like

FreedomBox has systemd-timesyncd enabled default on all platforms except when running on container (which are supposed to provide correct time if the host is properly setup). Sometimes setting the correct time on the system may be effected because of internet connectivity.

@Jacob, on your system, at that time, perhaps systemd-timesyncd was not installed (we fixed a small issue with it recently and made sure that all systems now have systemd-timesyncd).