[Solved] buster-backports public key is not available Raspberry pi 1b

Hello,

I installed Freedombox by this way: [debian wiki]/FreedomBox/Hardware/Debian
using Raspbian Buster Lite.

All is alright, but today I tried to install Coquelicot and I get this error:

Error during installation W: GPG error: http://deb.debian.org/debian buster-backports InRelease: The following signatures couldn’t be verified because the public key is not available: NO_PUBKEY 04EE7237B7D453EC NO_PUBKEY 648ACFD622F3D138 E: The repository ‘http://deb.debian.org/debian buster-backports InRelease’ is not signed.

1 Like

Solved after running:

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 04EE7237B7D453EC
sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys 648ACFD622F3D138

3 Likes

Wow I’m dumb. I’ve been trying to change to backports for 10 minuets now just copying and pasting the link. I’ve been copying the number of visits to the website this whole time. For anyone is clueless as me, do not copy the number sounded by spaces after the domain name. :sweat:

1 Like

Not your fault, I think it’s pretty annoying that when you select this piece of code it selects also the number of click.

I can’t edit the message anymore but if anyone wants to add an advertisement about, feel free to do.

no need to use ubuntu keyservers though
probably keyring.debian.org, would be more adequate. Given you ca assume freedombox users would probably prefer to rely on the debian key reviewed keys. Instead of keyserver.ubuntu.com that is.

@i3_relativism I can’t edit my post anymore, if someone can, please feel free to edit my 2sd post using keyring.debian.org