Setup Samba on external ssd

I am trying to setup Samba with an external SSD on my freedombox. I am running into some problems however which I can use some help with.

Problem Description
The OS is running on a 128GB SSD. I want Samba on a second SSD for capacity reasons. I first formatted the external ssd with FAT32, to quickly learn that Samba does not support this (no support for vfat). Then I formatted it as ext4 as recommended by Samba. However, that really confuses the freedombox. Going to the storage tab gives a 500 error then. I also can’t open the Samba settings anymore.

Does somebody know how to fix this?


  • FreedomBox version: 23.5
  • Hardware: RaspberyPi 4
  • How did you install FreedomBox?: Self install

What the status log says on a 500 error page?

When I now connect the external ssd to the raspberryPi, the entire freedombox becomes unresponsive. Not even a 500 message anymore.

Below you can see how it is partitioned. The second image shows the content of the drive. I found an article for Samba which said something about the media folder. That is why that one is present but it didn’t resolve any issue.


I removed the manually created media folder. That allows me to reproduce the 500 error. After I enter my username and password on the login page, I get the error below. Is the drive somehow formatted wrong? My linux laptop is able to read the drive (although I need root because the PC user is not on the drive).


If using a Pi – does your USB drive have it’s own power supply? They can sometimes behave strangely if trying to draw power from Pi USB. Entire FB becoming unresponsive might suggest a power issue?

Hello @charlesfox

I have a Raspberry Pi 3B+ with freedombox installed on a ssd drive.
That ssd drive is connected to the Pi with a USB 2.0 to 2.5 SATA 3 Hard Drive 22 Pin Adapter Cable UASP Converter For SSD HDD The Raspberry Pi 3B+ as a USB 2.0 setup and Raspberry Pi 4 as USB 3.0 setup. They are different !

Regards: peter

So this might depend on what kind of Pi and HD it is.

I tried running a FB on I think a Pi 3B+ with a passport USB drive a few years ago and saw strange behaviour. Passports dont have their own power supply, they draw power over USB, and the Pi wasn’t able to provide enough reliably. Maybe working a bit sometimes but not reliably. I switched to an external USD drive with its own power supply and that fixed it. Not sure how that would play out for other Pi versions or HDs.

(I ended up moving away from Pis for FB in general – it was do fun every time we had a small power cut which turned off the Pi without shutdown and destroyed the internal SD card data. Small power cuts seem surprisingly common if you try to run a server for months or years, so much better to use a larger machine with a better storage device. Or at least get a UPS for the Pi. But for the price of that you might as well just buy a larger machine.)

No, it does not have a separate power supply. I have 2 ssd’s

  • 1 128GB ssd (connected via a sata->usb adapter) which I use for the OS.
  • 1 512GB (also connected with a sata->usb adapter) which is the one I want to use as external drive for samba.

The interesting thing is, if I format the second drive as fat32 and not ext4, then the freedombox just recognizes it fine.

Hi @vincentvd

I also use a Pi4 for my FBX and it has issues with multiple (more than one) usb drives. Thats why your problam is probably not samba but that your disk isnt getting enough “juice” to operate properly.

The Pi4 is not designed to power more than 1 external disk from usb. You can hack your board but will void warranty and will have to provide a larger power supply than the original pi adaptor.

Another route you can take is

a. get a drive with its own power supply
b. get a usb-hub with a power supply and connect your disk(s) to that.

If you go with the second option, make sure to buy a hub that doesnt have power feedback (otherwise youll have other issues out of scope of this post). I use a UGreen brand that worked out fine but you can do a search online for alternatives.

Hope it helps.

Thanks for the reply. The only interesting thing left then is why does the freedombox recognize the drive when it is formatted as FAT32 but completely freezes when I connect an EXT4 drive?

why not try attaching single disk with ext4 first and fat32 later. id be curios myself to see what difference it makes.

Well, I have 1 main (USB) disk where the freedombox OS is stored on. I don’t use an SD-card for booting. So I can’t really switch.