Samba share not accessible

Problem Description
I am trying to use the samba share from freedombox running on a raspberrypi 2 using an external SSD. In the webinterface i can see that samba is installed and the group share is enabled. The SSD is mounted. When i try to connect via PCManFM to the share i get Failed to mount Windows share: Invalid argument, Dolphin just prompts me for the user credentials over and over. In the samba logs i get:

  Unknown parameter encountered: "access control"
  Ignoring unknown parameter "access control"

I already read multiple of the samba related topics here, but nothing really helped.(for example network is there and enabled and file permissions are correct) The location is also accessible via terminal.

Steps to Reproduce

  1. Login to FreedomBox.
  2. Go to Samba application page.
  3. Click on the install button.
  4. Select ‘Enable group share’ option for external SSD.
  5. Try to connect to share with filemanager.

Expected Results
Samba share gets mounted.

Actual results
I get an error with the following message:

Failed to mount Windows share: Invalid argument


  • FreedomBox version: 23.6
  • Hardware: RaspberryPI 2
  • How did you install FreedomBox?: downloading RaspberryPI 2 image from

Okay, checking the log.smbd i saw connection denied and then an ipv6 address.
Tried connecting to the share directly via ipv4 address rather than domain/discovery and that works. So seems to me like ipv6 not working for samba?! Is there a way to fix that?

I have a tendency to force IPv4 internally so I set network settings to that effect on a number of devices, including my router.

Have you checked that nothing is blocking IPv6 on network and that IPv6 is enabled and an address assigned to the FB?

Its probably not this but I figured I’d ask before someone who knows better than I the technical details on Samba joins the discussion.

How does your IPv6 address look like? It seems for Samba we are only allowing local IPv6 addresses in the ranges [::1], [fc00::]/7, or [fe80::].

(Configuration source:

You’re right, the IPv6 address in the logs is the public one. :thinking:
I tried to connect either via freedombox.local or by what was discovered in the local network by the filemanager.

I opened an issue to track this:

1 Like