RPI3B - WiFi and VPN not working

I have FreedomBox set up on a Raspberry Pi 3B connected to internet via an ethernet cable.
The Pi creates its own WiFi network called “FreedomBoxwlan0”, but when I connect to it, it says Internet not available. I tried visiting multiple websites and connecting to IPs but nothing work except for freedombox.local.

When I connect to the Pi through a VPN (OpenVPN server), I can’t visit any website including freedombox.local. The error from my phone is ERR_ADDRESS_UNREACHABLE

I forwarded the following ports: 80, 443, 1194.

How can I fix those issues?
Thanks in advance

Check whether you have a firewall policy to forward traffic from the internal zone to the external zone. From the command line (e.g., in a Cockpit Terminal window), enter “firewall-cmd --get-policies” and look for something like “int_to_ext_fwd”.

You might want to take a look at this thread and this thread.

1 Like

Thank you for replying. I checked the firewall with your command and it only says: allow-host-ipv6.

I checked the threads you linked, just to be sure, do i have to do all the following commands?

// create new policy
firewall-cmd --permanent --new-policy int_to_ext_fwd
firewall-cmd --permanent --policy int_to_ext_fwd --add-ingress-zone internal
firewall-cmd --permanent --policy int_to_ext_fwd --add-egress-zone external
firewall-cmd --permanent --policy int_to_ext_fwd --set-priority 100
firewall-cmd --permanent --policy int_to_ext_fwd --set-target ACCEPT

// Enable masquerade on external (this should already be the case if the setup worked on F34); ‘forward’ does not need to be set
firewall-cmd --permanent --zone=external --add-masquerade

// Enable forward on internal (this is a new setting)
firewall-cmd --permanent --zone=internal --add-forward

// restart firewalld
systemctl restart firewalld.service

1 Like

I vaguely recall getting a (harmless) message at some point in the sequence that something was already done, but I think I just did them one by one as listed (adding sudo before each one).

Hello, sorry for the delay.
I wrote the commands i sent in this thread and yes, i received the warning “Warning: ALREADY_ENABLED: masquerade”.

Now it works, but the connection speed is extremely slow. I have 1Gbps in download when connected to my home modem, and 1Mbps when connected to the Pi 4 (during the process I reinstalled FBX on a new RPi4). Do you have any idea why?

EDIT: I would also like to know if those commands could put any security risk to the data stored on the Pi, as I am using it as a NAS with nextcloud. Thank you in advance :slight_smile:

My suspicion would fall on the WiFi connection. You could check the usual WiFi suspects (Pi 4 near a source of interference, I had WiFi trouble when access point was too close to a power strip with several plugs in use; client too far from access point, Pi 4 doesn’t have an external antenna and may not have great range), but I’m not sure how else to troubleshoot. Check throughput in Cockpit? Use a USB-Ethernet adapter to substitute a hardwired connection for Wifi?