Roundcube 'server' field missing (configuring Roundcube to use external e-mail)

FreedomBox connection: plugged into router
FreedomBox version: 23.20


One of my FreedomBox users wants to be able to use Roundcube with his GMail account, so I unchecked the box which says to use only the local e-mail server. Unlike in the manual’s screenshots, I do not see a field to specify the IMAP server, as there are only fields to enter the username and password. Any entry into these fields returns an error about not being able to connect to the storage server.

Things I have done:
-Updated FreedomBox to latest version
-Ensure Frequent Feature Updates are on
-Changed setting to use more than local mail server
-Read the FreedomBox manual for Roundcube
-Checked Roundcube official wiki

When I uncheck the box in the Roundcube settings, which part of the config is this really affecting in the background? Is it necessary to manually change it, and if so, does the FreedomBox implementation differ from any regular installation of Roundcube? If it doesn’t, then I should be able to follow any instruction I find.

I appreciate your time.

This is an issue for FreedomBox. There was a change to the configuration options in Roundcube 1.6.0 that was missed. I opened an issue for it here:

I was able to get the Server field to appear by making changes in the config. You would need to modify these 2 files:

  • /etc/roundcube/config.ini.php
    • Comment out these lines (by placing // at the beginning of the line):
      • $config[‘imap_host’] = [“localhost:143”];
      • $config[‘smtp_host’] = ‘localhost:587’;
  • /etc/roundcube/
    • Comment out these lines (by placing // at the beginning of the line):
      • $config[‘imap_host’] = ‘localhost:143’;
      • $config[‘smtp_host’] = ‘localhost:587’;

Thank you for your response. I followed your instructions and the server field appeared, though I found that the files were *.inc.php rather than *.ini.php. Perhaps that’s a recent change? However, when my user enters his username, password, and server as imaps://, it returns the error ‘Login failed’. The link for the Less Secure Apps page is no longer functional, though there is an option to enable IMAP within GMail, which he has.

Changing imaps:// to imap:// returns a ‘connection failed’ error. Is there something else within those config files I should change in order for it to work?

Thanks for all your work on the FreedomBox project.