Rockpro64 image wont boot from eMMC

Problem Description
I burned the freedombox-bullseye-free_all-arm64.img and freedombox-testing-free_latest_all-arm64.img to a eMMC card and tried to boot my rockpro64 from it.
the system does not boot

Steps to Reproduce

  1. download an image linked from the rockpro64 page
  2. write it to an eMMC chip with a usb eMMC reader writer
  3. install chip on rockpro64
  4. apply power
  5. no booting happens

Expected Results
I expected it to boot

Actual results
green light turns on and Ethernet lights turn on but the white led never turns on and the board never boots

Information

  • FreedomBox version: latest stable and testing image
  • Hardware: rockpro64
  • How did you install FreedomBox?: wrote image to emmc

I believe this is a known problem with some images on the Rockpro64

on this page ROCKPro64 Software Release - PINE64 it says

If you are trying to boot from an eMMC module then the 4.4.y will work, but the newer 5.10.y will not.

might be nice to note that in the page on the rockpro64
even nicer would be to fix it or have an alternative image for that purpose

FYI I worked around this problem by booting a Armbian image and installing freedombox from there

Hi @freepm. Welcome to the forum!

The image you used is a generic FreedomBox image for ARM64 devices which does not ship with device-specific firmware. Please refer to the section “2. Hardware Supported with Generic Images” in the following wiki page.
https://wiki.debian.org/FreedomBox/Hardware

The same is also mentioned on the download page of the website.

For reference, I am running kernel version 5.18.0-0.deb11.4-arm64 from eMMC (on Debian though).

Just to confirm, did you flash the u-boot firmware to SPI flash?

https://wiki.debian.org/FreedomBox/Hardware/RockPro64#Download

As I remember, that was the only thing required to get it working.

On RockPro64 | FreedomBox - Personal Server at Home
This is the link for downloading the firmware
https://ftp.freedombox.org/pub/freedombox/hardware/arm64/stable/freedombox-bullseye-free_all-arm64.img.xz

I think its intended that I use the generic image

No I did not flash the SPI since I thought, perhaps incorrectly, that a board made in 2022 would have the firmware from 2021.

I’ll see if I can find a card to try that out

I made the same mistake like @freepm because when clicking on “download”, one gets to RockPro64 | FreedomBox - Personal Server at Home that does not mention flashing SPI and clicking on the question mark just tells you to verify and just below flash what you have downloaded.

Now, I followed the instructions at Flashing U Boot to SPI · sigmaris/u-boot Wiki · GitHub but the white led won’t turn on when applying the power.

My setup has the NAS case and two HDDs, the fan is off but the HDDs seem to be on (slight noise and some heat).

Does that mean I need to get some device for the serial console to have a clue what is happening?