Restoring backup has no effect

Problem Description
Restoring backup produces no effect. A message "Restored files from backup. " is shown, but the apps keep their “just installed” state.

Steps to Reproduce

  1. New install of FB, up-to-date.
  2. Restore backup, with all or only some options checked.
  3. Tried with apps not yet installed, installed but disabled, as well as installed and enabled.

Actual results
No visible backup restoration.


  • FreedomBox version: Debian GNU/Linux bookworm/sid and FreedomBox version 21.8. FreedomBox is up to date.
  • Hardware: OLinuxino-Lime2
  • How did you install FreedomBox?: from downloaded image, burnt on SD card with etcher.

Is there documentation on the procedure to restore backups ? Also, is there a way to do it on the CLI to maybe have more verbose results ?

Thanks for your help.

We have automated functional tests for many apps that ensure that backup and restore work. See, for example, MediaWiki’s backup/restore functionality test.

If you give more details steps of what you tried (app name and data stored) and expected outcome, we might be able to trace the problem.

MediaWiki is the most important in my use case, so I’ll focus on it.

I did two backups of the whole FB, using the included backup system. Each time, I kept all options checked. I then downloaded these and stored them compressed in .7z, rather than .tar.gz.

To restore, I first went back to .tar.gz, then used “Upload and restore”.
Then, if I keep all options checked and click “Restore”, I get a 502 Proxy Error.
I then tried to remove most other apps from the backup, thinking it might be too large (but made sure to keep the mediawiki parts, both in etc and var). Then, I am still offered all options checked by default, even though I do not have the data for most app.
If i keep everything checked, I get the same error, while if I check only mediawiki, I get the "Restored files from backup. " message. But then, going to the wiki page, it has the default main page and nothing else.

If you know things to test here, I can try, else I guess I will redo the install. The FB even seems to be much slower than before, so maybe something went wrong during the install…

I proceeded with the new install, using the latest weekly image for Pioneer. While the performance issue is gone, the backup restoration still fails for all apps. The apps do get reinstalled, but nothing more.
I guess it must means my backups are flawed for some reason… so I guess I will have to do without. ¯\_(ツ)_/¯

Sorry about that.

Are you able to extract your backup archives and read the files inside?

BTW, images not being backed up for MediaWiki is a reported issue which will be fixed by v21.9, but you should’ve gotten your pages back when restoring the backup.


I have the backup files, but unfortunately, it is in the form of a sqlite database, which I have no idea how to read.

For the images, I had seen this issue and thus saved them separately, so at least I have access to those. And I’m glad to learn that it’ll be fixed in the next version ; thanks for your work ! :slight_smile:

MediaWiki’s database in FreedomBox is in the form of a single SQLite file.

If restoring using the Backups app didn’t work, you can try a manual restore.

  • Disable MediaWiki from the app page.
  • Make a copy of the existing sqlite file to your home directory just in case the file from your backups doesn’t work.
  • Place the sqlite file from your backups at /var/lib/mediawiki-db/my_wiki.sqlite
  • Run this command as root to fix the file permissions.
/usr/share/plinth/actions/mediawiki setup
  • Enable MediaWiki and check if your data is back.

Thank you for your help.
I followed these steps and now get an error message in mediawiki :

Database error

A database query error has occurred. This may indicate a bug in the software.

[a62d866b708fb87b7466850d] 2021-09-10 18:03:39: Fatal exception of type “Wikimedia\Rdbms\DBQueryError”

Is this a known thing ?

Looks familiar.

But then, DBQueryError is a common error that could be caused by various reasons. The same fix might not work for you. :zipper_mouth_face:

1 Like

I have been able to solve the issue using the same method as the linked thread.
Thanks a lot for your help !