RESOLVED: Freedombox lost connection to my network - reboot?

If you are asking for support for an issue, please include the following information at the top of your post:

  • Whether your FreedomBox is plugged into a router at home or not (if not, please specify how it is connected to the internet)

Into router by ethernet.

  • The month and year you bought your kit (feel free to omit if you want to preserve some privacy, but this could be helpful information)

December 2022

  • The version of FreedomBox your are running (available by clicking on the “?” in the top menu → “About”)


I just got my freedom box and all was working well but it has lost connection to my network - how do I reboot it. Of course I can’t just pull plug because of battery.

Do I need to pull plug open up, disconnect battery, reconnect battery and power up again?

Any advice appreciated.


Hi, have you fixed the issue yet?
There should be a small reset button you can press to reboot the box. Here’s some details:

I recently lost connection with my FreedomBox too but couldn’t get the reset button to work this time (it worked last time I tried but it’s a bit fiddly to reach on my box). I unplugged it and waited a few hours for the battery to run out before plugging it in again and it’s fine now. I’ve also opened it up and unplugged the battery before which works but the plug doesn’t feel too sturdy so I avoid that method now.

1 Like

Thank you!!!

I did not know there were reset buttons - can try that next time.

Yes I resolved it pulling the plug and disabling the battery but I hoped someone would have a more elegant solution.

Thank you again for the reply.

1 Like

Thank you for the reset button picture; I needed it today.

1 Like