Recover freedombox from shutdown?

I finished setting up my FreedomBox a few days ago. All was working great. Today I decided I did want battery backup after all(had disconnected battery for setup).

Now system will not come back up. Here was the sequence of what I have done and tried so far:

  1. ssh’d into server and did a “sudo shutdown -h now” to turn off FreedomBox
  2. disconnected power and ethernet
  3. reattached battery cable
  4. reattached ehternet and then power cable
  5. waited 10 mins, no response, although red light on inside case
  6. pressed soft on/off button at far left of case for 5 seconds
  7. no response - ethernet cable lights not on either
  8. tried another soft on/off cycle, Still no response nor ethernet lights.

Any suggestions? I thought of trying the hard reset button (middle button) but don’t want to do that unless I have to…

EDIT: to add to the above even a hard reset does not work. The only way to get functionality was to remove the battery plug and simply use it on mains power. ???

EDIT #2: after some research it appears this has been a common problem and appears to be some sort of hardware bug? I have not seen any solutions yet? Anyone??