Raspberry Pi 4, Model B, not showing up

Problem Description
I downloaded a fresh nightly image for the raspberry 4, model B and verified it. After putting it on an micro-SD Card, inserting it and waiting for 10 minutes, it won’t show up in my Huawei HG659. I can’t find an ip-address either. The raspberry pi is connect through the ethernet port with a CAT 7 ethernet cable. The cable is attached before starting the device. I’m not using any other modem or switch. Both the red light and the network indicator lights are flashing. I’ve tried reaching the raspberry pi through the firefox browser on an Arch Linux install.

Why won’t it show up? What can I do to solve this? Should I open some ports? Any help would be greatly appreciated.

Second Problem Description
I’m facing the same problems with my raspberry pi 3, model B+, with an stable image, except, the network indicator lights won’t flash on this device.

Expected Results
Being able to connect to the device through freedombox(.local) or an IP

Actual results
Device(s) not reachable or showing up in my router’s firmware interface.

Can you assign a static IP address? FreedomBox uses NetworkManager. Mount the SD card on Arch Linux. Navigate to /mount/point/etc/NetworkManager/system-connections/

You should see a *.nmconnection file for the Pi’s ethernet cable connection. Here is my ipv4 section.


Here, try this. Its a temp fix though.

sudo systemctl stop firewalld

This guy figured it out. After a reboot though Firewalld service restarts.

I also use fing as my network IP scanner. If it doesn’t show up there, this solution won’t work.

1 Like

Thank you for replying. No such file is present. As soon as my microHDMi cable arrives today, I will look at the errors on the screen. I have also tried the seperate uefi driver on a micro-sd, yet nothing boots.

Thanks. I will try and see if it boots up tonight.

So apparently this worked. I got it running on a debian image for raspberry pi, by hooking op a monitor. I didn’t try this method yet.

Now I got it running on a raspbian OS lite image. This doesn’t seem to be a permanent solution however. Is there a way to always allow internal traffic (within the network) but not allowing external incoming traffic?

Edit: I got it fixed by settting a static ip in Arch and adding it to the internal zone of firewalld on freedombox. I did a lot of searching today but I finally did it.

1 Like

Nice, I’ll try to do something similar on my machine later.