Raspberry Pi 4 - Freedombox 19.1 - Can't update

Hello,

Recently setup a rPi4 with Freedombox. I was running Raspberry Pi OS and installed freedombox via the terminal with the debian instructions. It installed version 19.1. I have tried to update manually via the update tag on the system section of plinth with no results.

What’s the best way to get up-to-date Freedombox on my rPi4

Simplest way is to wait for a day or two. FreedomBox will setup the repositories needed and upgrades will happen automatically after that. If you want it immediately, run:

sudo /usr/share/plinth/actions/upgrades setup-repositories
sudo unattended-upgrades -v
2 Likes

Here’s what I got from the terminal in _cockpit

"outoftown@raspberrypi:~ $ sudo /usr/share/plinth/actions/upgrades setup-repositories
Repositories list up-to-date. Skipping update.
Preferences up-to-date. Skipping update
outoftown@raspberrypi:~ $ sudo unattended-upgrades -v
Checking if system is running on battery is skipped. Please install powermgmt-base package to check power status and skip installing updates when the system is running on battery.
Initial blacklist :
Initial whitelist:
Starting unattended upgrades script
Allowed origins are: origin=Debian,codename=buster,label=Debian, origin=Debian,codename=buster,label=Debian-Security, o=Debian Backports,a=buster-backports,l=Debian Backports
Packages that will be upgraded: "

Still showing Freedombox 19.1 in about section

Could you list your apt sources in /etc/apt/sources.list, /etc/apt/sources.list.d/* and /etc/os-release ?

I followed the same method to install Freedombox on a RPI4 as the OP and I am having similar troubles…

I got to the Freedombox login page, but it is stuck on 19.1. I have tried to upgrade it using the GUI tool, and by following the command line suggestions above in ssh.

At some point in running the commands above the pi definitely imported new repos, but did not import the GPG keys. I imported the GPG keys.

The forum didn’t let me post all the URLS below… h++p is what it should be.

/etc/apt/sources.list looks like this:

deb h++p://raspbian.raspberrypi.org/raspbian/ buster main contrib non-free rpi
#Uncomment line below then ‘apt-get update’ to enable ‘apt-get source’
#deb-src h++p://raspbian.raspberrypi.org/raspbian/ buster main contrib non-free rpi

/etc/apt/sources.list.d/freedombox2.list looks like this:

#This file is managed by FreedomBox, do not edit.
#Allow carefully selected updates to ‘freedombox’ from backports.

deb h++p://deb.debian.org/debian buster-backports main
deb-src h++p://deb.debian.org/debian buster-backports main

/etc/apt/sources.list.d/raspi.list looks like this:

deb h++p://archive.raspberrypi.org/debian/ buster main
#Uncomment line below then ‘apt-get update’ to enable ‘apt-get source’
#deb-src h++p://archive.raspberrypi.org/debian/ buster main’

/etc/os-release looks like this:

PRETTY_NAME=“Raspbian GNU/Linux 10 (buster)”
NAME=“Raspbian GNU/Linux”
VERSION_ID=“10”
VERSION=“10 (buster)”
VERSION_CODENAME=buster
ID=raspbian
ID_LIKE=debian
HOME_URL=“h++p://www.raspbian.org/”
SUPPORT_URL=“h++p://www.raspbian.org/RaspbianForums”
BUG_REPORT_URL=“h++p://www.raspbian.org/RaspbianBugs”

Did you wait a Day or two?

Note that Raspbian is not Debian, and it does not include the keys to install packages from Debian’s buster-backports repository. There is a way to add these keys manually.

TL/DR:
I’d consider this solved.
Run the commands sunil suggested
Import the GPG keys it says it needs when you try to update it.
Run “sudo apt upgrade” manually once the computer realizes there is in a new Freedombox version.

My previous post was made when the installation was about 3 hours old, but based on sunil’s post the commands should have forced a full system upgrade.

I imported the GPG keys for the Debian repos that were added as part of what I did on Thursday.

I left the pi running over the weekend, and it still shows 19.1 after a manual reboot. The about page shows that there is an update available, but the web/GUI tool does not update anything when a manual update is requested. The update logs didn’t show any skipped updates after this.

I ran “apt list --upgradable” in terminal, where I saw that the current version (20.16) is available. This is great, and the system upgraded to the current version after manually running “sudo apt upgrade” in terminal*. But shouldn’t the box upgrade its self? That’s how this system was sold (for free, I appreciate what were getting here.)

In the grand scheme of things this is a minor inconvenience if you know to look for it, and it will probably fall into “fringe cases” but hopefully the experience helps someone else trying to install Freedombox on a Raspberry Pi4

*I think there was an issue with one of the repos which slowed down the updates SIGNIFICANTLY. I ran sudo apt upgrade -y several dozen times, downloading maybe 1-2 packages at a time until it spit out a rejection message. Considering this, I would appreciate it if anyone could comment on my various sources.list files and if they should be updated.