Random Crashing of Freedombox (Solved)

Since the last system upgrade to Bullseye my Pioneer would randomly crash. Samba, Open VPN, and Wordpress are running along with a website serving video and music from a piggybacked 5GB SSD. After 3 or 4 days the system would become unreachable through all methods (SSA, internet, direct connection to FB). I tried to replace the single board computer to no avail. Evidently the power requirements from the FB server and the SSD exceeded the power supply that came with the Freedombox. I replaced the power supply with one that supplies 5A and the server has not failed since.
Hope this helps.

Thanks for the tip!

I got the version with a disk with which Olimex provides a 2A power supply. I had somehow given it up as the disk was randomly disappearing and reappearing. I guess the power supply is not enough, so I need to get another one. However, I don’t have much clue on how to choose a suitable power supply.

Is there anything to be especially careful about for the choice of the power supply? Which model are you using?

I used a spare 5V 5A DC power supply from an old Netgear router that I was no longer using. You DO NOT want to use a battery charger power supply as these actively change output in response to the state of charge of a battery. A quick search on Amazon using “5V 5A Power supply” gives many choices. You just need to be sure that the plug is identical to the one that plugs into the Freedombox.