Problems installing on Beaglebone Black

I have tried many times to install FreedomBox on BBB. They all failed.

  1. Downloaded the BBB stable and testing files. I flashed each to a usb using etcher onto a micro sd. However, the BBB won’t boot from the sd when I use the FreedomBox images. The BBB boots from the sd card when I install debian for BBB.

  2. I installed the latest release of Debian for BBB (9.9). Then I followed the instructions from the FreedomBox website for installing in Debian. During the install process the system locks up and doesn’t complete. I tried several times.

  3. Then I installed Debian 10 for BBB from this site I was able to boot from micro sd and start installing Freedombox. I made much more progress, but still there were hangups and when I rebooted I couldn’t find FreedomBox on the micro sd. So now I am in the middle of the process of trying the install fresh again on Debian 10 for BBB.

4 I flashed the FreedomBox image for amd64 (for my Lenovo x200) and attempted to boot from usb. However, I was given a login prompt before the install process even started. I don’t know the username or password.

Should I try installing onto QEMU? Does this have any downsides in terms of the speed of the server? Would I get better privacy protection when using QEMU?

Can anyone help me with this?

See below the following error I get after trying number 3 above:

Created symlink /etc/systemd/system/dbus-org.fedoraproject.FirewallD1.service → /lib/systemd/system/firewalld.service.
Created symlink /etc/systemd/system/ → /lib/systemd/system/firewalld.service.
Setting up apache2 (2.4.38-3+deb10u3) …
Enabling module mpm_event.
Enabling module authz_core.
Enabling module authz_host.
Enabling module authn_core.
Enabling module auth_basic.
Enabling module access_compat.
Enabling module authn_file.
Enabling module authz_user.
Enabling module alias.
Enabling module dir.
Enabling module autoindex.
Enabling module env.
Enabling module mime.
Enabling module negotiation.
Enabling module setenvif.
Enabling module filter.
Enabling module deflate.
Enabling module status.
Enabling module reqtimeout.
Enabling conf charset.
Enabling conf localized-error-pages.
Enabling conf other-vhosts-access-log.
Enabling conf security.
Enabling conf serve-cgi-bin.
Enabling site 000-default.
info: Executing deferred ‘a2enmod auth_pubtkt’ for package libapache2-mod-auth-pubtkt
Enabling module auth_pubtkt.
Created symlink /etc/systemd/system/ → /lib/systemd/system/apache2.service.
Created symlink /etc/systemd/system/ → /lib/systemd/system/apache-htcacheclean.service.
Job for apache2.service failed because the control process exited with error code.
See “systemctl status apache2.service” and “journalctl -xe” for details.
invoke-rc.d: initscript apache2, action “start” failed.
● apache2.service - The Apache HTTP Server
Loaded: loaded (/lib/systemd/system/apache2.service; enabled; vendor preset: enabled)
Active: failed (Result: exit-code) since Wed 2020-01-29 05:56:48 UTC; 112ms ago
Process: 11831 ExecStart=/usr/sbin/apachectl start (code=exited, status=1/FAILURE)

Jan 29 05:56:47 beaglebone systemd[1]: Starting The Apache HTTP Server…
Jan 29 05:56:48 beaglebone apachectl[11831]: (98)Address already in use: AH00072: make_sock: could not bind to address [::]:80
Jan 29 05:56:48 beaglebone apachectl[11831]: (98)Address already in use: AH00072: make_sock: could not bind to address
Jan 29 05:56:48 beaglebone apachectl[11831]: no listening sockets available, shutting down
Jan 29 05:56:48 beaglebone apachectl[11831]: AH00015: Unable to open logs
Jan 29 05:56:48 beaglebone apachectl[11831]: Action ‘start’ failed.
Jan 29 05:56:48 beaglebone apachectl[11831]: The Apache error log may have more information.
Jan 29 05:56:48 beaglebone systemd[1]: apache2.service: Control process exited, code=exited, status=1/FAILURE
Jan 29 05:56:48 beaglebone systemd[1]: apache2.service: Failed with result ‘exit-code’.
Jan 29 05:56:48 beaglebone systemd[1]: Failed to start The Apache HTTP Server.
Setting up gir1.2-gtk-3.0:armhf (3.24.5-1) …
Setting up libqmi-proxy (1.22.0-1.2) …
Setting up python3-acme (0.31.0-2) …
Setting up python3-certbot (0.31.0-1) …
Setting up php-fpm (2:7.3+69) …
Setting up certbot (0.31.0-1) …
Created symlink /etc/systemd/system/ → /lib/systemd/system/certbot.timer.
Setting up modemmanager (1.10.0-1) …
Created symlink /etc/systemd/system/dbus-org.freedesktop.ModemManager1.service → /lib/systemd/system/ModemManager.service.
Created symlink /etc/systemd/system/ → /lib/systemd/system/ModemManager.service.
Setting up freedombox (19.1) …
Created symlink /etc/systemd/system/ → /lib/systemd/system/freedombox-setup-repositories.timer.
Created symlink /etc/systemd/system/ → /lib/systemd/system/freedombox-udiskie.service.
Created symlink /etc/systemd/system/ → /lib/systemd/system/plinth.service.
freedombox-setup-repositories.service is a disabled or a static unit, not starting it.
Processing triggers for fontconfig (2.13.1-2) …
Processing triggers for mime-support (3.62) …
Processing triggers for initramfs-tools (0.133+deb10u1) …
update-initramfs: Generating /boot/initrd.img-4.19.82-ti-r33

Did you see a FreedomBox logo along with the login prompt?

There isn’t a username and password. When you see the logo and login prompt, that means that FreedomBox has started in the background. You need to access the web interface to create the first user account. This is usually done from another device (PC or mobile) on the same network.