Plinth login page gives HTTP 500

My SSH user doesn’t work and plinth login page gives 500. I can connect a keyboard, but have no SDcard reader at hand. What are my options to recover access?

  • Make sure the SSH login attempt is with a user account that belongs to admin account.
  • You can access the built-in web-based terminal available in Cockpit. Cockpit can be access without depending on Plinth. Cockpit is app that is enabled by default. It is available at https://<your_domain>/_cockpit/.
  • Please post the details of the 500 error page (although I believe the details are only available if you are a logged in user). That might give us further ideas.
  • See if disk is full, try clearing some space (say by removing some files from syncthing folders).

Seems like the same issue I had about 6 months ago and never got a response to:

I wiped the whole thing and started from scratch, and that worked for a while, but eventually the problem returned. Then I didn’t turn my FreedomBox device on for a few months, but when I did just last week, it magically worked again.

Unfortunately when you re reporting that you cannot login to a box gives very limited information of what the actual problem might be. For example might be a corrupt database in the web ui case.
Your best bet of fixing the issue (if there is one) is to plug a monitor to your box and try to find the service logs (for plinth the web ui that is journalctl -u plinth).
If there is an actual bug there and the problem is not your box, you ll also help to improve the quality of the software.

The problem is I don’t have much more information and can’t log in with keyboard/monitor either.

Maybe there’s something I could press to enter recovery mode and get a root shell.