Plinth broken after autoupdate [FIXED]


Removed libaugeas0: apt-get remove libaugeas0
which removed a lot of other things including freedombox.
Then I reinstalled the things that got removed:
apt-get install augeas-tools freedombox freedombox-setup libaugeas0 python-certbot-apache python3-augeas python3-certbot-apache

After an automatic update, my freedombox’s plinth is broken. I’ve tried reinstalling freedombox, apache2, apache2-bin, apache2-utils

Also tried “systemctl restart plinth; systemctl restart apache2” as well as rebooting to no avail.

My /var/log/apache/error.log shows:

[Sat Apr 24 19:53:40.940467 2021] [proxy:error] [pid 8969] (111)Connection refused: AH00957: HTTP: attempt to connect to ( failed
[Sat Apr 24 19:53:40.942318 2021] [proxy_http:error] [pid 8969] [client] AH01114: HTTP: failed to make connection to backend:, referer: https://freedombox.local/plinth

FWIW, I can ssh into the freedombox. Just don’t have any webinterface.

systemctl status apache2

● apache2.service - The Apache HTTP Server
Loaded: loaded (/lib/systemd/system/apache2.service; enabled; vendor preset: enabled)
Active: active (running) since Sat 2021-04-24 19:52:36 UTC; 19min ago
Docs: Apache HTTP Server Version 2.4 Documentation - Apache HTTP Server Version 2.4
Process: 8909 ExecStart=/usr/sbin/apachectl start (code=exited, status=0/SUCCESS)
Main PID: 8933 (apache2)
Tasks: 8 (limit: 2299)
Memory: 31.5M
CGroup: /system.slice/apache2.service
├─8933 /usr/sbin/apache2 -k start
├─8935 /usr/sbin/apache2 -k start
├─8965 /usr/sbin/apache2 -k start
├─8966 /usr/sbin/apache2 -k start
├─8967 /usr/sbin/apache2 -k start
├─8968 /usr/sbin/apache2 -k start
├─8969 /usr/sbin/apache2 -k start
└─9048 /usr/sbin/apache2 -k start
root@freedombox:~# systemctl status plinth
● plinth.service - FreedomBox Service (Plinth)
Loaded: loaded (/lib/systemd/system/plinth.service; enabled; vendor preset: enabled)
Active: activating (auto-restart) (Result: exit-code) since Sat 2021-04-24 20:12:24 UTC; 3s ago
Docs: man:plinth(1)
Process: 12136 ExecStart=/usr/bin/plinth (code=exited, status=1/FAILURE)
Main PID: 12136 (code=exited, status=1/FAILURE)

Running manually:

/usr/bin/python3 /usr/bin/plinth

Traceback (most recent call last):
File “/usr/lib/python3/dist-packages/django/apps/”, line 122, in create
cls = getattr(mod, cls_name)
AttributeError: module ‘plinth.modules’ has no attribute ‘avahi’

During handling of the above exception, another exception occurred:

Traceback (most recent call last):
File “/usr/bin/plinth”, line 6, in
File “/usr/lib/python3/dist-packages/plinth/”, line 139, in main
File “/usr/lib/python3/dist-packages/plinth/”, line 51, in init
File “/usr/lib/python3/dist-packages/django/”, line 27, in setup
File “/usr/lib/python3/dist-packages/django/apps/”, line 85, in populate
app_config = AppConfig.create(entry)
File “/usr/lib/python3/dist-packages/django/apps/”, line 127, in create
File “/usr/lib/python3.7/importlib/”, line 127, in import_module
return _bootstrap._gcd_import(name[level:], package, level)
File “”, line 1006, in _gcd_import
File “”, line 983, in _find_and_load
File “”, line 967, in _find_and_load_unlocked
File “”, line 677, in _load_unlocked
File “”, line 728, in exec_module
File “”, line 219, in _call_with_frames_removed
File “/usr/lib/python3/dist-packages/plinth/modules/avahi/”, line 13, in
from plinth.modules.config import get_hostname
File “/usr/lib/python3/dist-packages/plinth/modules/config/”, line 9, in
import augeas
File “/usr/lib/python3/dist-packages/”, line 78, in
class Augeas(object):
File “/usr/lib/python3/dist-packages/”, line 82, in Augeas
_libaugeas = _dlopen(“augeas”)
File “/usr/lib/python3/dist-packages/”, line 75, in _dlopen
raise ImportError(“Unable to import lib%s!” % args[0])
ImportError: Unable to import libaugeas!

Anybody got any ideas on how to fix? Thanks.

So is libaugeas0 installed now?

I don’t understand why it was removed in the first place. Is there any context in the upgrade logs to explain this?

libaugeas0 wasn’t missing. For some unknown reason, python3 couldn’t import it.

I finally fixed the problem by removing libaugeas0 (and automatically all those things which depended upon it). Then I reinstalled it (and all those things which got automatically removed).

I had tried running python from the command line and then importing augeas but got same error about “unable to import” even though I had the pyton library file

I’m new to debian. Don’t know if debian has a python configuration checker to check and fix problems.

Had first tried the following, but everything had came back with clean bill of health and nothing needing to be removed or re-installed:

#apt-get update
#dpkg –-configure -a
#apt-get -f install
#apt-get clean