Pine64 Rock64 does not boot (eMMC, SD)

I have a Pine64 Rock64 (not RockPro64) I would like to turn into a FreedomBox. I flashed its image onto its eMMC module and plugged it in. I see a red light, a white light, and the Ethernet port’s light come on, but no other activity. I leave it for 15-20 minutes, and FreedomBox has not installed.
I tried flashing the image to an SD card, and received the same. This model of the Rock64 is the one without SPI flash, but I attempted to install and flash u-boot via an SD card the same way, to be sure. Nothing changes. I know there is a similar thread with a user who has the RockPro, but I think the RockPro handles things differently.

Problem Description
Pine64 Rock64 does not install FreedomBox.

Steps to Reproduce

  1. Flash freedombox-bullseye-free_all-arm64.img to eMMC module using USB adapter sold by Pine64 and dd command. Double-check for flashing .img and not .tar
  2. Place eMMC module on Rock64
  3. Plug in Ethernet cable, then power cable
  4. Wait 15-20 minutes

1b. Flash freedombox-bullseye-free_all-arm64.img to SD card using USB adapter and dd command. Double-check for flashing .img and not .tar
2b. Place SD card inside Rock64. Ensure card is not popping out
3b. Same as above
4b. Same as above

1c. Flash u-boot-flash-spi-rock64.img to SD card using USB adapter and dd command. Double-check for flashing .img and not .tar
Remaining steps same as above

Expected Results
Some flashing light activity from the Rock64, and to be brought to the FreedomBox’s Plinth setup page when I type freedombox.local

Actual results
Static red light is on the Rock64
Static white light is on the Rock 64
Ethernet port light shows activity
No connection to freedombox.local
No sign of Rock64 in router listed devices


  • FreedomBox version: latest stable
  • Hardware: Pine64 Rock64 4GB with 64GB eMMC module. Product page indicates unit no longer sold with SPI flash when purchased
  • How did you install FreedomBox?: download stable image from FreedomBox website

I’ve not got a lot of experience with Pine machines but this stands out.
What DNS is being used to resolve this address?
Can you scan the network, discover the IP address, and navigate to it rather than using “freedombox.local”?

No, there are no signs of life. While the Ethernet port on the Rock64 shows activity, the switch to which its attached doesn’t light up to show its plugged in. I can’t find it in my router interface, either.

Are you sure your device is operational? Meaning, did you try other images/distros?

Successfull flashing of uboot should be indicated by changing in lighted diodes. Did you observe such a change?

It will be beneficial to connect to the serial console of the device to actually see what’s going on during the boot if it even boots. Pine64 - has section how to connect the serial. The USB to serial modules are fairly inexpensive. Stay away from FTDI ones and get CH340 based if you dont have one.

1 Like

Sounds like the system is not operational/booting.

I’d verify the hardware is good by loading a different distro on it, as stoyan suggests. If that works, then his solution of tapping in via serial might reveal what’s happening. I don’t have any experience doing this so I can offer no advice on how to do this.

No, I did not. The lights were static when I tried flashing u-boot.
When I purchased my Rock64, the page shows it is a unit no longer sold with SPI Flash, so I assume it has something to do with this.

At your and timmy’s suggestion, I decided to give Armbian a try. I placed the SD card inside and plugged the Ethernet cable before plugging it in. I had success installing it and am able to SSH into my Rock64.

From here, I assume I can just install the FreedomBox package from the command line. I’m still curious as to why the FreedomBox image wouldn’t boot, however.

Perhaps there will be a clue as you install FreedomBox. A package that doesn’t work right or throws an error that will give some clue to report to the FB team.