Matrix - Registration and Login

I have installed Matrix on my olimex fredombox, it runs version 19.2.

Matrixsynapse is running.

Then I installed nheko, because as far as I know, riot allows until now not multible servers.

Then I tried to register with a username, password, and the homeserver

But registration does not work.

Any ideas?

You can directly login into your Matrix server with the credentials of an existing FreedomBox account.

Or enable public registrations in your Matrix Synapse app in FreedomBox to create more accounts. Remember to turn it off later if you don’t want to keep public registrations open.

Thanks. Registration did work after I changed to freedombox.

Did you configure the domain name as ‘’ while installing Matrix Synapse?
Also check the domain name in System -> Configure

If your Matrix server thinks that your domain name is ‘freedombox’, it will not be able to federate with other Matrix instances. Unfortunately, there isn’t a way of changing the domain name after installing Matrix Synapse.

Yes, i did configure it as, which was the only possible choice.


Check out our video tutorial for Matrix/Riot on FreedomBox. If you follow all the steps exactly as instructed, you should be able to use Matrix and Riot.

Thank you. I watched the video, which is very helpfull. But I had configured everything the way it should be.
For the Matrix cliet I use nheko. I could register with nheko and log into my account.
I could make a new room and see the user i registered.

I tried to log in from another laptop in and outside from my home network. Unfortunately the homeserver was not found. Can the reason be, that I did not succeed in obtaining a certificate for matrix

In the topic " Let’s Encrypt “Failed to obtain certificate …”" is the descripton of what happened to me.

To me when I register my at GnuDip I cannot log in with it, the browser says java is not running, However to my best knowledge it is enabled. I am kinda lost by this.

Can you reach your FreedomBox from outside its network by typing the public IP address in the browser?
If not, check if you did port forwarding / DMZ correctly in your router.

The message "Java is not enabled in your browser. " is only shown after a successful login AFAIK. Also, Java is not really required. You can ignore the error message. It is not recommended to enable Java in your browser for security reasons.

You can verify that it detected the correct IP address by going to a site like which shows your public IP address.

Hope your registration at the GnuDIP website was successful. While logging in, make sure that you selected “” as the domain. If you forgot your password, you can try the button called “Forgotten Password”.