Login for USB in order to install

Hi all, I’ve created a Debian Sid Freedombox USB which I assumed would offer an automated installer, and I’ve booted into it in order to install to hard drive on my old laptop which doesn’t have an ethernet jack.

The first screen of the Freedombox USB and it tells me it is Debian GNU … sid freedombox tty1, and then presents options for connecting via http and/or a login below that. This machine has no ethernet jack and only wifi, which obviously is not configured yet. I’ve tried to log in with various combinations of freedombox/debian/admin/root to no avail.

Question 1: What is the login for the USB?

Question 2: Once booted into the Freedombox USB, is there a standalone installer to install to the machine (and not use the USB)?

@deepdark , what image did you put on your flash drive?

Your setup is a bit different than mine, but I believe to install Freedombox on an old laptop like you describe you first do a fresh install of Debian (connect to wifi network, et cetera). Then you install Freedombox as a package through apt.

This page might be helpful for getting yourself set up: FreedomBox/Hardware/Debian - Debian Wiki

You may be able to use this resource to help get Debian installed on your laptop, if it is on here: InstallingDebianOn - Debian Wiki

From what I understand, the pre-built Freedombox images don’t really work unless you are using an SD card for booting. I might be incorrect on that, but a few posts on the forum discuss migrating off of the SD card and for whatever reason the system remains dependent on the SD card for booting. So it is possible the pre-built Freedombox images might not work with a USB installation.

1 Like

Install Debian. Manually bring WiFi drivers and firmware on your USB if needed.

Install FB by:
DEBIAN_FRONTEND=noninteractive apt-get install freedombox

Then comment out your WiFi entry in /etc/network/interfaces

Reboot into freedombox

Thanks for the reply, @BluishHumility . I also suspect this is the case. Looks like this should be mentioned on the download page or install wiki. I’ll grab the freedombox app from debian repos instead. Thanks

@joseph that’s also a good comment about brining wifi drivers. Thanks

Hello @deepdark

I run Freedombox on a old laptop my self and from what I have learned. I would say it would be best if you first install a debian base and then Freedombox on another laptop first, that as a Ethernet port. Just put the hard drive from the old laptop on to other laptop ? that as Ethernet connection.

I do not use the Debian installer and it Wi-Fi option ! to install a debain base and then freedombox. If you are installing a desktop the Wi-Fi option is OK.

When you use the Debian installer and it Wi-Fi option for a command line setup only. At the end of the debian install and a reboot. The Wi-Fi setting will not be saved, so no Wi-Fi connection when the operating system is up and running. That why I use a computer with a Ethernet port to install debain and then freedombox.

Once you done a basic debian install. That is just a command line setup, no desktop.

It a good idea to setup sudo:

as root:

apt install sudo

Now add the user you created with the debian installer to the sudo group.

usermod -aG sudo username

Now install freedombox on the debian basic install.

sudo DEBIAN_FRONTEND=noninteractive apt install freedombox
After the freedombox package as been installed you need to edit the network file called ‘interfaces’.

sudo nano /etc/network/interfaces
So that only what shown below is in the ‘interfaces’ file.

``
auto lo
iface lo inet loopback
`
Hash out the lines that are not needed with # at the beginning of the lines you do not need.

Now that freedombox package as been installed and the interfaces file as been edited. It is time for a reboot and start the freedombox setup it self.

The reboot will fortunately stop at the rescue mode. You need to login as root.

There is a bug relating to the software ‘snapshot’ that was installed along with freedombox. snapshot: Does not mount /.snapshots correctly with Debian installer created btrfs

To temporarily get pass this point you need to edit a file called ‘fstab’.

Login as root and edit the file fstab.

nano /etc/fstab

Hash # out the line:
#UUID=/very-long-number /.snapshots btrfs subvol=.snapshots 0 1
After this is done, reboot the laptop and you will now be able to get a full boot and start the setup of freedombox.

From a web browser on your local network go to that your freedombox is on go to http://freedombox.local and start your freedombox setup.

All the best and regards: peter

2 Likes