I messed up: from networking issues to (almost) full access blockage

Hmmm. That was a strange journey for a couple of days since I received my Pioneer Box.

First issue:
I noticed that my FreedobBox was disappearing from the local network during the night.
It’s been still somewhat working because I could see the LEDs working, but I needed to restart it by unplugging the power cord and plugging it in again.
And only after such a hard reboot, I was able to ping it and access it through SSH.
So I was wondering if I could try checking the logs to figure out what is happening during the night.

The journalctl didn’t say much. It was even lacking the whole 2-3 day worth of history.
I tried looking into /var/logs/syslog, but it wasn’t there. So, with the help of ChatGPT, I managed to install and set the rsyslog running and decided to look into the logs the next day…

Issue number two:
Meanwhile, I wanted to pimp up my SSH access a bit. I have always been a fan of the fish shell so I installed it.
But changing the shell was also not that obvious. I didn’t understand why, but I couldn’t see my username entry in /etc/passwd. (It was far too late when I realised that there’s LDAP setup in the Freedombox)
I tried doing it the hard way and I manually added my username entry into the /etc/passwd… and this broke a lot!

  • I don’t have access through SSH anymore
  • I can’t login to Cockpit (“Permission denied”)
  • I only can still access plinth web interface, but can’t even add new users as there are some errors showing up…


  • is there a way to hard reset the box to the starting point where I could set everything up again?
  • what could have been the network drop issue in the first place?

OK! Flashing the SD Card with the official Pioneer image was good enough for this state of things.

Let’s see if I’ll face the network disappearance again…