How to restore a backup?

I could not reach my freedombox anymore and decided to do a re-install. I am running Freedombox on a Raspberry Pi 3B+. I reflashed the card and tried to upload and restore the latest backup. I got an internal 500 error and submitted a bug report.

I might be doing something wrong here, most likely. Do I need to re-install the apps and then upload and restore the backup or are the installed apps already included in the backup?

When I go through the logs it shows that when the backup is trying to restore the apps, it goes wrong when trying to install the first app, matrixsynaps. The error is

Unable to correct problems, you have held broken packages.

I tried launching the Cockpit on the new bare install. I can login with the admin account but only a blank page is shown and no possibility to get to the terminal, to work around the broken packages problem.

There is a problem with installing Matrix Synapse currently. A workaround is to first install the package from backports: sudo apt-get -t buster-backports install matrix-synapse. You will need to do this before restoring the backup for Matrix Synapse.

But how do I get to the terminal? I used to fire up Cockpit but when I do that and login I just get a blank page.

Have you set up DDNS and Let’s Encrypt? Maybe your problem is there.

My experience is that cockpit works when you access it using a dns name which is matched by your Let’s Encrypt certificate. I cannot log onto cockpit with IP in the address bar of browser, only with the FQDN in the address bar.

This is by design, and annoyed me until I understood that this is for protection of the system.