How to connect to the Freedombox Samba share?

I have installed the Samba app and now I am trying to connect from my Linux box, Ubuntu 16.04, to the Freedombox share.

The file manager, named Files, sees the Freedombox and I need to login to get access. I connect as “Registered user” and it asks for the follwoing:

Username:
Domain: WORKGROUP (default)
Password:

No matter what I try, sofar, the message is:

Unable to access location
Failed to mount Windows share: Invalid argument

What are the right incantations to get this working?

There is one known permission issue with the Freedombox. To fix this, log in to the Freedombox and run this command in the terminal:
sudo chmod 755 /var/lib/freedombox/

Does it solve your case? You should be able to connect to the share as “Anonymous” or “Registered user” with any user/password.

1 Like

Setting the permissions allows me to login/mount indeed. But the shares which have been enabled/ticked do not show up. Should the permissions extend to the subdirectory /var/lib/freedombox/shares?

Every share should be mounted separately. If you have shared multiple disks, those should show up in the file manager under Network -> Freedombox. I think permissions are now correct but if you still don’t see other shares, could you send the output of the command (from the Freedombox):
sudo net conf list

[disk]
path = /var/lib/freedombox/shares/open_share
guest ok = yes
read only = no
force group = freedombox-share
inherit permissions = yes

Try this - go to the Samba configuration page, then refresh the page (F5) and only then enable additional shares.

If it didn’t help, could you send more information (label, mount point, type) about the additional disks you want to share.

Refreshing and then enabling did not make a difference. Below a screenshot of the disk(s) shared:

Let me know if I understand your problem correctly. You have enabled sharing on device /dev/mmcblk0p3 and this works correctly (as you said you can mount ‘disk’ share). And you want to enable a share on device /dev/mmcblk0p2 and this doesn’t work?

Nope,

I have enabled sharing on /dev/mmcblk0p3. The Freedombox shows up on my File Manager and with the permissions set I can now enter/mount the disk/share. But no files and or directories are shown. There is just an empty space shown. In short the content of the share is not shown, even though it is enabled and I can enter as an anonymous user or registered user in the File Manager.

By default, a share should be empty because only one directory is shared (/var/lib/freedombox/shares/open_share). Can you copy files to this mounted share from your desktop PC?

Ah, OK, I misunderstood the concept of a share then. I thought I would be able to traverse through all files and directories on the partition once enabled for sharing. Still learning here… Thanks for your patience.

And I can indeed copy files to this mounted share from my linux box.