High background cpu usage

for the past several weeks, my freedombox unit () has had high background cpu usage (~30-98%).

the culprit seem to be high
apt-get and packages background activity.

i have rebooted several times and it has not changed.

perhaps it is trying to update to freedombox 20.14.1?

i have not noticed this behaviour in the past. how can i determine if my system is corrupted/compromised in some way?

1 Like

Package installations are usually CPU intensive processes. Check if unattended-upgrades is running when you observe high CPU usage.

If you observe that the package installation never finishes running, then it is worth killing the process and trying apt -f install to fix any broken package installation.

Thank you very much njoseph (killing apt-get and restarting unattended-upgrades) but this did not work either.

I am left with the following (output from top first line):

14635 root 20 0 48532 44140 35624 R 98.4 4.3 0:03.09 apt-get

after running apt -f install

Reading state information… Done
0 upgraded, 0 newly installed, 0 to remove and 1 not upgraded.

after running apt dist-upgrade
Calculating upgrade… Done
The following packages have been kept back:

it appears that matrix-synapse is also intermittently high in the background, although I have disabled this. Is my system trying to upgrade to 20.14.1 unsuccessfully?

Any thoughts? Should I just disable unattended-upgrades? My server performance is starting to slow as a result.


This appears to relate to matrix synapse indeed. The logs are full of the message below:

Error running setup - (‘matrixsynapse’, ‘’, ‘Traceback (most recent call last):\n File “/usr/share/plinth/actions/matrixsynapse”, line 89, in subcommand_public_registration\n with open(REGISTRATION_CONF_PATH) as reg_conf_file:\nFileNotFoundError: [Errno 2] No such file or directory: ‘/etc/matrix-synapse/conf.d/freedombox-registration.yaml’\n\nDuring handling of the above exception, another exception occurred:\n\nTraceback (most recent call last):\n File “/usr/share/plinth/actions/matrixsynapse”, line 135, in \n main()\n File “/usr/share/plinth/actions/matrixsynapse”, line 131, in main\n sub_command_method(arguments)\n File “/usr/share/plinth/actions/matrixsynapse”, line 93, in subcommand_public_registration\n with open(ORIG_CONF_PATH) as orig_conf_file:\nFileNotFoundError: [Errno 2] No such file or directory: ‘/etc/matrix-synapse/homeserver.yaml’\n’)

fyi - in case it helps - i purged matrix synapse using apt and it seems to have resolved the issue.

finally back to baseline load average.