Freedombox will not boot up on my Debian desktop

I have installed Debian on my desktop using debian-10.1.0-amd64-netinst
After install i went in terminal and typed sudo apt-get update but there were no updates.
then i typed $ sudo DEBIAN_FRONTEND=noninteractive apt-get install freedombox
Everything seemed to work OK then it ended with processing a number of triggers for …
Rebooted but back in Debian
Tried $ sudo DEBIAN_FRONTEND=noninteractive apt-get install freedombox-setup
Cannot remember now what happened
Then tried $ sudo /usr/lib/freedombox/setup | tee freedombox-setup.log
but did not recognis commant
Tried rebootin - back in debian
How do i get into freedombox from here?
I followed the instructions on this page
https://wiki.debian.org/FreedomBox/Hardware/Debian

Just had another go

Can someone help me get Freedombox running on my desktop?
I have installed Debian 10 OK but did not use a root password, just a user password.
Used this page for instructions https://wiki.debian.org/FreedomBox/Hardware/Debian
Opened terminal
typed sudo apt-get update
it fetched 65.3kb then read package and done
typed sudo DEBIAN_FRONTEND=noninteractive apt-get install freedombox
says needs to get 102mb of archives i type y enter
does a whole lot of stuff unpacking and preparing etc
setting up freedombox 19.1 and still going.
Now stopped last 9 lines has been processing triggers.
Now this is where i reboot and end up back in Debian.
How do i get into freedombox from here?
where do i go from here have been trying for past 15 hours getting tited now.

Since it is trying every time to download packages you dont have installed the freedombox meta package. Additionaly apt-get install doesnt reboot the system on its own even when upgrading important system components.

The reasons for the restarts are usually hardware related. Common reasons of sudden restarts:

  • Overheating, check the BIOS cpu temp immediately such a reboot. The thermal paste on the CPU might need replacing.
  • Bad hardware (disks mainly), you ll have to run badblocks to see what is reported for the condition of your disk.
  • Bad power supply. Quite basic.

Hope this helps.

@Mybox Have you checked if you can access the web interface like in https://wiki.debian.org/FreedomBox/Manual/QuickStart ?

Or if you also have a desktop environment running on the same system, you could try https://localhost in the browser.

Have been trying everything but no luck.
Just re-installed Debian to have another go after many tries.
Installed Debian
Opened Terminal
type sudo apt-get update
type sudo DEBIAN_FRONTEND=noninteractive apt-get install freedombox
The end of the install read

Created symlink /etc/systemd/system/multi-user.target.wants/plinth.service → /lib/systemd/system/plinth.service.

freedombox-setup-repositories.service is a disabled or a static unit, not starting it.

Processing triggers for fontconfig (2.13.1-2) …

Processing triggers for desktop-file-utils (0.23-4) …

Processing triggers for mime-support (3.62) …

Processing triggers for hicolor-icon-theme (0.17-2) …

Processing triggers for gnome-menus (3.31.4-3) …

Processing triggers for libc-bin (2.28-10) …

Processing triggers for systemd (241-7~deb10u1) …

Processing triggers for man-db (2.8.5-2) …

Processing triggers for dbus (1.12.16-1) …

Processing triggers for resolvconf (1.79) …

debconf: DbDriver “config”: /var/cache/debconf/config.dat is locked by another process: Resource temporarily unavailable

dpkg: error processing package resolvconf (–configure):

installed resolvconf package post-installation script subprocess returned error exit status 1

Errors were encountered while processing:

resolvconf

E: Sub-process /usr/bin/dpkg returned an error code (1)

root@mydebian:/home/glorybox#

Then i tried to get the secret key

root@mydebian:/home/glorybox# /var/lib/plinth/firstboot-wizard-secret

bash: /var/lib/plinth/firstboot-wizard-secret: Permission denied

root@mydebian:/home/glorybox#
At a complete loss what to do

Did you get any errors while first installing the OS?

You could attempt the following:

sudo rm /var/cache/debconf/*.dat 
sudo apt purge freedombox
sudo apt autoremove
sudo apt clean
sudo apt update
sudo apt install freedombox

In case you have broken packages for whatever reason it s not necessary it will fix the issue.

As an alternative you can try the Freedombox amd64 image from the official downloads.

Thank you for the help.
Tried everything i can think of but just keep getting bogged down at reboot. No matter what, i cannot log out of Debian and boot into Freedombox.
Some time ago, when i used the virtualbox file, when i rebooted after install, it rebooted into Freedombox and i got the log in screen.
Unable to do that from a Debian intall on a desktop PC
I am expecting that when i reboot Debian it will boot into Freedombox and not into Debian. Is that correct because if it is then i cannot get it to work.
Or maybe i am supposed to boot into Debian then open Freedombox somehow. I am confused.

You mean you tried the above (my previous reply)? Can you retry and post here the output? As you re providing very limited information on what might the actual problem be.

After successful install of freedombox you dont even have to reboot. It s already running.

FreedomBox is a server operating system. You will not see anything different after installation on your monitor as it has no desktop GUI.

FreedomBox is a pure blend of Debian, which means FreedomBox will be indistinguishable from any Debian system. After installing the freedombox package on Debian, you wouldn’t see any visible difference at least on the desktop.

FreedomBox only offers a web interface, no desktop or command line.

You should connect to your FreedomBox web interface using a browser. After a successful installation of FreedomBox, try either https://freedombox.local or find the IP address of the machine from your router’s clients page and type it in instead of freedombox.local.

It is more convenient to use an i386 or amd64 image of FreedomBox directly instead of installing on Debian if you have physical access to the hard drive.

To print the firstboot-wizard-secret, you have to use the cat command.

root@mydebian:/home/glorybox# cat /var/lib/plinth/firstboot-wizard-secret

Thank you very much for your help.
I admit i did not give all information, I replied when i was in a state of despair and frustration as i have been spending most of my life trying to get this running. Sorry for not giving extra information.
Extra information
I am probably more difficult to help than most because i am not a technical person. Also i am in my late 70s so a bit slower at picking things up.
I followed your instructions and they did work, however i got a lot of questions which i was unsure how to answer
1st message
Please enter the Uniform Resource Identifier of the LDAP server. The format is “ldap://<hostname_or_IP_address>:/”. Alternatively, “ldaps://” or “ldapi://” can be used. The port number is optional.
When using an ldap or ldaps scheme it is recommended to use an IP address to avoid failures when domain services are unavailable.
Multiple URIs can be separated by spaces.
LDAP server URI
ldap://127.0.0.1/ Just left it at this default
2nd message
Configuring nslcd
Please enter the distinguished name of the LDAP search base. Many sites use the components of their domain names for this purpose. For example, the domain “example.net” would use “dc=example,dc=net” as the distinguished name of the search base
LDAP server base"
dc=home Note: I changed this to dc=glorybox
3rd message
Please enter the password for the admin entry in your LDAP directory.
Administator password
******** I used XyZ123 my Debian root logon
confirm password
******** I used XyZ123
NEXT
Configuring libnss-ldapd
For this package to work, you need to modify the /etc/nsswitch.conf file to use the ldap datasource.
You can select the services that should have LDAP lookups enabled. The new LDAP lookups will be added as the last datasource. Be sure to review these changes.
Name services to configure:
passwd
group
shadow
hosts
networks
ethers
protocols
services
rpc
netgroup aliases
oops
I hit enter and it started to load
now recieve the secret 4Br7/OeA3sI+9oJ9

Also as this desktop pc does not have wireless i am using ethernet cable. So i have to install when connected to the internet moden then conect cable to another pc
I am sure now that the problem has been me trying to get the same boot up log-in screen i got when i used Virtualbox.
When i used the Freedombox for Virtualbox downlod and had it running i did some testing.
First i installed the TOR network and that was all OK then i installed the P2P file share and that installed OK. Then i went to insatll another App and it said drive full.
I can expand the virtual disc drive but i would have to look up instructions. Also my main aim is to run Freedombox on a PC so rather than trying to learn how to expand the virtual drive i went back to trying my desktop…
Thank you for all the help it is appreciated.
I will work on reinstalling Freedombox and spend more time on other PC finding the connection (IP address)

With the steps you re describing you definitely have freedombox installed.

Since I assume you have physical access on the PC if you have installed also a desktop environment there you can access freedombox by accessing on the browser https://localhost.

If you do not have a desktop environment setup in that PC (it will be a server anyway) you can find the ip address by typing on your terminal: ip addr show - ignore the localhost one(127.0.0.1) and the second one you see should be accessible from other PCs in your house. So go in a browser and put the discovered ip address.

After that you simply follow the steps after step 5 in the quick start guide https://wiki.debian.org/FreedomBox/Manual#FreedomBox.2FManual.2FQuickStart.Quick_Start

Hope this helps.

Thank you for your help.
I now have Freedombox up and running.
Clearly the problem i had was looking for a boot up log in.
One strange thing happened with Freedombox setup. I could not get a username to work.
I tried all sorts of things
myfreedombox, and 2 myfreedombox and 2,mfejle3843h98 and all sorts of stuff but nothing worked.
Then i put in a single letter g and it worked. So my username is g
I will now spend some time learning to use it.
Once again thank you very much for your help.