FreedomBox now available in Raspberry Pi Imager

FreedomBox is now available as an operating system that can be selected in Raspberry Pi Imager [1] [2], a user-friendly tool for creating bootable media for Raspberry Pi devices. FreedomBox can be found in the section “Other specific-purpose OS” when Raspberry Pi 4 or Raspberry Pi 3 is selected as the device. Images are available using Debian stable and testing.


Thanks to @lifeform and @sunil for working on this. With Raspberry Pi being a very popular device, this will definitely let many more people know about FreedomBox. :tada:


[2] GitHub - raspberrypi/rpi-imager: The home of Raspberry Pi Imager, a user-friendly tool for creating bootable media for Raspberry Pi devices.


I understand that RPi4 includes the RPi400 as well
Is it so?.

Yes, but I found that for the RPi 400, you need to use the “testing” image. The stable image is missing some firmware that is needed by RPi 400.

1 Like

Thanks! I’ll try it!

Hiya all, I have been trying for a few days no to get FreedomBox working on my raspberry pi and I am getting to the point where i am pulling out what is left of my hair. It just will nt work at all!

I get to the point where i am given a IP for the webserver and a page that states its loading, please wait. After that i just keep getting errors and other issues.

I have used both stable and unstable and makes no diffrace. I have also tryed diffrent flashing tools, again makes ni diffrace. the picture atached is the code that just keeps going on and on and on.

I hope someone out there can assist? Thank you

We might need some more details here, but those BTRFS errors seem to indicate that there are issues with your storage device, specifically /dev/sda2. Is that device an SD card?

@thephil2006 what model Pi do you have and is it connected to a router (or somewhere) via the Ethernet port? The brcmfmac -52 errors are related to the Broadcom wireless driver. The screenshot also shows BTRFS (filesystem) errors. Besides trying different flashing tools, did you try a different SD card? Maybe the card is bad.

I am using a Pi 4 8GB Ram, I am running the software from an SSD, I have tried another and a mechanical harddrive too and still have the same issues.

I have not tried using an SD card as of yet but it is something I can try.

The Pi is connected to a router via 2 swiches. I have a USB Ethernet dongle plugged in too as I would like to put the box at the start of the network and protect all devices after.

I hope the above answers your questions.
Thank you so much for the help, it’s honestly appreciated. Phil

I have just swapped the SSD from the USB 3.0 port to the USB 2.0 and it booted up staright away…

1 Like

This is an issue with the pi4 and the usb connecting cable to its USB3.0 port. I’ve read on other forums that this may be resolved with specific cables/casings. I had the problem too and like @thephil2006, the only way I resolved it (with the cable I had) was by connecting to the USB 2.0 port.


1 Like