FreedomBox not visible from the Internet, not working, error 500

After installation, FreedomBox is not visible from the Internet. Rebooting the router does not help.
The Let"s Encrypt certificate cannot be downloaded (see screenshot).

Whelp, looks like let’s encrypt is not grabbing the certificate.

I’m not sure how the domain is setup but I doubt you own it or at the least have a DNS record for pointed to your IP address.

I have owned the domain for several years. My freedombox has always worked on this domain.

My bad. First try at dig threw an error that made me think it didn’t exist.
Turns out spelling is still important.

I see an ip address in dig. Have you checked to ensure the DNS record matches your current host internet IP?

Next question- is there a router in front of this device and has it gotten an update recently? If so, have you checked to ensure required settings are still correct? Have you rebooted it?
I only ask because I had a bit of fun here with the latest pfsense update. Behaved a little wonky until I rebooted it again.

I rebootet the router, it does not help. I chtcked the router settings, everything is correct there. I have not updated the riuter software.

This my third time installing FreedomBox, the first two everything went fine. This time FB is not visible from internet and i don"t understand why. With dig i don"t understand. What exactly should i do?

dig is just a tool for me to see if my machine (and thus any machine) can get a DNS resolution.

I assume you are co-located with the rpi. Without any TOR, VPN, or such running, goto and see if the IP address it shows matches, which is what I get from dig for your domain.

If not, then you will need to update that record. My freedombox runs on a domain I maintain and so I don’t know how the thing is setup to work or where you go to update that information.

If so, then something isn’t working with letsencrypt and we’ll need to examine that further. I’ll probably be near the end of my usefulness but maybe we’ll have attracted some attention from more knowledgeable people by then.

Ip-chicken shows it correctly: this adress is the same as the one prescribed for my FB. As Dynamic DNS Service I use
Problem after problem :frowning: now FB is inaccesible on local network too.
In any case - thanks!

I’d just try reinstalling and watching/reading carefully to make sure some option hasn’t changed that you might accidentally mark incorrectly.

Reinstalled Freedombox.
It is still not accessible from the Internet.
It is not possible to install the Let"s Encrypt certificate (screen1).
Diagnostic shows problems with certificate (screen 3) and DNSSEC (screen2).
Thank you in advance for your help.

It’s worse than it seemed at first glance. It doesn’t work at all. Maybe it’s a bug in the software. The screenshot shows an error 500, which is not caused by the user’s actions and cannot be fixed by him. It is impossible to download the error log, FB does not respond.

Can you SSH in to the device?

I can, but I don’t know what to do there. I have reinstalled FB four times on two different media, the result is the same: from the Internet side it is not visible, and the error 500 is repeated with different user actions. There is something malfunctioning inside, and it should be handled by someone who understands more than me.

From here, we can access logs and such.

You can navigate to the letsencrypt log with:

cd /var/log/letsencrypt/

then open letsencrypt.log with your text editor of choice like nano or vim and we can review the logs.

We can also see the output of

journalctl -xe


systemctl status

note any components that are in error or reported errors.