Freedombox + monitor + keyboard = prompt doesn't accept input

Trying to troubleshoot, I plugged a monitor directly into my Freedombox Pioneer with an HDMI cable, and a keyboard directly into it via USB.

I got a Freedombox username prompt, but it would not accept any input, nothing was being returned on the screen when I entered my username and hit the return key.

Hitting the return key several times did not cause the prompt to repeat on successive lines as it normally would. I tried two different keyboards, both of which otherwise function perfectly.

I’m unable to get a DHCP lease when it’s ethernet-connected to my router. I plugged the SD card into my computer and everything on it looks fine (at least to my untrained eye).

Where might I go with this from here? Thanks for any ideas.

I have exactly the same problem, I already tried to reinstall new software however the freedombox is not getting a correct IP address.

Could it be a hardware problem?

Not sure, but to update my previous post, whereas my router previously would not assign a DHCP lease to the Freedombox, it has now assigned a DHCPv6 lease (which it did a few days ago as well. At that point I just wanted a v4 lease but played around and ended up with no lease).

I got a lease assignment to happen by doing a full reboot of the Freedombox by unplugging both the Freedombox’s power cable and its battery. (Why the lease assigned was DHCPv6 instead of v4, I have no idea - maybe my router is trying to nudge things toward v6 in general, which, now that I think about it, isn’t a bad idea.)

So I’ve decided to get myself up to speed with understanding IPv6, and setting things up to get things working in both IPv6 and v4. Then maybe I’ll be able to bring up Freedombox’s web interface. I’ll report back with any results (though I may well have more questions before that happens, fingers crossed).

Meanwhile it would still be good to know why I couldn’t get any input from a keyboard plugged in directly, if anyone might have clues about that.