Freedombox.local not working but direct IP is

Today I installed freedomboxon my RaspberryPi 4 but I cannot access my freedombox via freedombox.local. I had to lookup the LAN IP adres to connect to my box successfully. As a result, I cannot use Cockpit because it requires a URL and not an IP adres.

After some searching, I made a DNS rebinding exception for the domain in my router/modem (Fritzbox) but that did unfortunately not resolve the issue. I also have NextDNS configured in my router but disabling that does also not resolve the issue.

Does somebody know how to fix this?

I found a fix that works for 1 minute. Disable and re-enable “service discovery” in my freedombox. After a minute, the .local domains becomes unresolvable again.

Can you edit /etc/hosts on your computer (not the FreedomBox) and add a line to resolve the page to your device? freedombox.local

That would be mine, obviously for yours use whatever IP you assigned your FreedomBox in your router.

Thank you for your reply, I was able to change that file and now it works on my laptop. Via my VPN it also works on my phone but via my VPN on my chromebook it doesn’t. Why doesn’t freedombox.local work out of the box?

:man_shrugging: Mine did! Everyone’s network is different.

Once you get your domain set up you won’t have to worry about that anyway; you can add the domain as an internal site on your home router, and external networks will connect through a normal DNS provider. The freedombox.local address is just a placeholder until you get that set up.

Under System >> Configure try to set the Hostname to “freedombox”

Cockpit wants to have a validated SSL certificate to work.

  1. Your freedombox configuration page should have a simple hostname
    1.1 Hostname: yourhostname
  2. Set up dynamic DNS and get a gnudip account
  3. Back in the Configuration page fill in the Domain Name
    3.1 Domain Name: (domain only, no host name here)
  4. Set up Let’s Encrypt to get an SSL host certificate for
  5. Go to and it will work

I believe that cockpit is designed to not work if you connect directly to your local IP address or freedombox.local.

Regarding the manual /etc/hosts modification, I don’t go that way myself. I have been avoiding configuration other than through the Freedombox interface - and have not found a good reason to manually modify config files yet. I was a unix sysadmin in a production environment in a past life - I’m not afraid of that. I’m just trying to keep my Freedombox experience the way it was intended. This has been working very well for me - I have a happy and stable freedombox that I can absolutely count on.

1 Like

And is it also possible to get a domain and a certificate without making the freedombox public on the internet? I dont want and need that because i installed a vpn. It would be nice though if all devices on my LAN can access the box by a url instead of the ip and without a security warning.

Presumably your FreedomBox is on the internet, otherwise you would not be able to pull down updates. As far as getting a certificate and a domain, it is basically just a check to verify your machine is broadcasting from the IP address it says it is. You aren’t exposing your device any more than you are by visiting this very website in a normal browser.

As far as how accessible you would like your FreedomBox to be, that will be up to you–you are welcome to hide it away behind your gateway and only forward the port you use your VPN on, for example.

For me, setting up a DDNS service has been very valuable because my ISP does not serve us a static IP address. It is very rare for it to change, they mostly leave it alone, but there was one time I tried to connect using our IP address and could not because it had been changed temporarily to an IPv6 address (our normal IP address was presumably being used for something else at the time). Not having to worry about that because I have the DDNS service is nice.