External Access - access Pioneer from the Internet

Dear FreedomBox team, let me first thank you for this amazing project and opportunity to decentralise and privatise bits and pieces of our online lives.

Initial info as required :

  • I run FreedomBox on a Pioneer edition, connected to my home router (& modem, just one piece of equipment)
  • Bought it in November 2019
  • Running v. 20.5

So I am basically testing my external via trying to connect to Mumble for example.

Here is the description of my setup :

  • I have created a domain name on GNuDip, with a username.
  • I have configured it to point to my public IP address (which doesn’t seem to be modified by my ISP).
  • On my router setup I have a DMZ pointing to local IP of the freedombox.
  • On my router setup I have configured port redirection for ports 80,443, and both TCP & UDP ports for Mumble

Yet I can’t access Mumble from outside my LAN with my public IP/mumbleport. However it works when I am connected to my LAN WiFi. I can access FreedomBox via Tor though, and can access Cockpit using the domain address for the Pioneer.

It seems Let’s Encrypt never delivered a certificate properly, can it be a cause of the issue ?

Finally Matrix Synapse always fail to install. Maybe for the same reason ?

Thanks for your help guys,

After trying many things, I reset the SD Card, flash the Freedombox OS to it and reinstall, and it worked magnificiently.

It seems that loosing the router/modem access for too long messes up with the configuration ? Or is it because I am missing something ?