Early Tiny Tiny RSS impressions

Overall Impressions

List of things you liked

  • Having control over the storage location of my RSS feeds.
  • The UI is very clean.
  • Seems stable.

List of things you disliked

  • I wasn’t able to create neither categories nor labels after installation (described in section below).
  • I’m having difficulties to connect an Android client because of certificate issues.
  • I’ve been unable to connect any other RSS client. Is it even possible?
  • I would prefer that their community forum didn’t have a category named “Gas Chamber”.

Unable to create categories and labels after installation

Summary
Right after installation, clicking “Create category” in the “Preferences” > “Feeds” menu does nothing.

Manually creating a category in the database solved the issue.

Description
Right after installation, clicking “Create category” in the “Preferences” > “Feeds” menu does nothing: no browser console errors, no requests to the server, I couldn’t even find a line in the Javascript to set a breakpoint for debugging. The same happens with labels.

Manually creating a category in the database solved the issue:

# As root
runuser -l postgres -c 'psql'

# Connect to ttrrs database
\c ttrss

# Determine your id:
SELECT id, login FROM ttrss_users WHERE login = '<YOUR_LOGIN_NAME>';

# List existing categories
SELECT * FROM ttrss_feed_categories;

# Create a category:
INSERT INTO ttrss_feed_categories(owner_uid, parent_cat, title)
VALUES (<YOUR_ID>, null, '<NEW CATEGORY NAME>');

From that point on, the categories are properly displayed in the UI and the “Create category” button works.

I haven’t tried this solution with labels (which still don’t work in my installation).

Proposed Solution
Tiny Tiny RSS code should be fixed. As a temporary workaround, some generic categories could be automatically added by FreedomBox as part a post-installation actions.

I’ve had no problems creating categories or labels through preferences, but I did notice that new categories didn’t show up on the main page until I edited an uncategorized feed and assigned it to the new category (picked from dropdown). Also, my Android client (1.301-fdroid) stopped working (SSLProtocolException:SSL handshake) around the time of FreedomBox release 21.9, which dropped support for SSLv3, TLSv1 and TLSv1.1. This is an old phone frozen in time at Android 4.3, so perhaps unrelated to your situation.

On my development container (testing) I was able to reproduce the issue with ‘Add Category’ button not working. @glalejos, it would be good to report this to upstream.

I have been using “Tiny Tiny RSS” client for quite a while. Remember to provide credentials in two place HTTP authentication and application authentication. Use the /tt-rss-app/ URL. Valid TLS certificate may be necessary though. You can absolutely can’t get Let’s Encrypt based certificate, try to add the self-signed certificate of FreedomBox to Android’s trusted certificate store using debug features.

Thanks for the inputs @lifeform, @sunil.
Before creating a new topic in ttrss forum [1], category support, I tried reproducing the problem in the latest version (repo [2], commit 3c30e416063c5ac77da27206d7e24d208962e6a3, Mon Aug 23 10:13:36 2021 +0300), but I coudn’t reproduce the issue.
So this might not be an issue anymore in latest versions of ttrss. Or maybe I’m using the wrong repository?
Regarding certificate issues (this might be better in a separate topic, you tell me), I’d rather try to go the right way. I don’t feel comfortable with HTTP-01 challenge because I don’t want to expose HTTP services to the Internet, but DNS-01 challenge [3] seems like an option that might work for me. Is there any discussion going around this? I think this could be very beneficial for FreedomBox (I couldn’t find it in the forum).

[1] https://community.tt-rss.org/
[2] fox/ttrss-docker-compose: Dockerized tt-rss using docker-compose - ttrss-docker-compose - Tiny Tiny RSS
[3] Challenge Types - Let's Encrypt