"Creating LDAP user failed" message after clean install and creating new user and password

Using a freedombox Pioneer Edition here.

  • Freedombox is plugged into a router at home
  • Bought the box less than 6 months ago.
  • FreedomBox version 20.19

I do a fresh install of Freedombox pioneer edition (Latest weekly image) with the dd command. Then, I insert sd card and wait for boot. Then, upon entering my new username and password after it asks me to, I get the following error message:

Creating LDAP user failed: ('users', '', 'No such object (32)\nMatched DN: ou=groups,dc=thisbox\nTraceback (most recent call last):\n File "/usr/share/plinth/actions/users", line 583, in <module>\n main()\n File "/usr/share/plinth/actions/users", line 579, in main\n subcommand_method(arguments)\n File "/usr/share/plinth/actions/users", line 315, in subcommand_create_user\n set_samba_user(username, password)\n File "/usr/share/plinth/actions/users", line 372, in set_samba_user\n timeout=10)\n File "/usr/lib/python3.7/subprocess.py", line 939, in communicate\n stdout, stderr = self._communicate(input, endtime, timeout)\n File "/usr/lib/python3.7/subprocess.py", line 1682, in _communicate\n self._check_timeout(endtime, orig_timeout)\n File "/usr/lib/python3.7/subprocess.py", line 982, in _check_timeout\n raise TimeoutExpired(self.args, orig_timeout)\nsubprocess.TimeoutExpired: Command \'[\'smbpasswd\', \'-a\', \'-s\', \'ShinaniGunz22x\']\' timed out after 10 seconds\n')

Could someone explain exactly what this means, and If I should be concerned at all? This doesnt seem like a typical output message in the webif after creating a brand new user and password. Help is appreciated!



Setting the Samba password failed (looks like 10 second timeout for this particular command is too short). If you plan to use the Samba app, then re-enter (or change) your password via the ‘Change Password’ menu. Otherwise your system should work just fine.

1 Like

@vexch Thank you for the help and input. But just so I properly understand whats heppening here can you confirm the following assumptions?

  1. Freedombox defaults are set to interrupt the samba password creation after 10 seconds, and carry on to the next step in the setup process. However, in this case, 10 seconds is not enough time for this particular piece of hardware to create the samba password, so this error is triggered.
  1. The consequence of this, is that the samba password is not created at all? or… the samba password is corrupted?
  2. Last of all, I am a bit confused, why upon initial boot, freedombox attempts to create a samba password when I havenent even had the opportunity to install, or activate the samba share app?

Just trying to gain some understanding here.
Thanks for your insight and help!

@Danrancan Good questions.

  1. Maybe the disk or cpu was busy doing other tasks at this time. This is not a common error on this hardware, increasing the timeout should help, I created an issue https://salsa.debian.org/freedombox-team/freedombox/-/issues/2000
  2. Not sure.
  3. A Samba password is created for every user to simplify the Samba app setup later because Samba uses different password database and encryption method.

@vexch, thank you for your answers.

Just to affirm that the error in the OP is not a totally isolated incident, I tried dd’ing a fresh image of freedombox again on a different mini sd card, and the events that took place after inserting it, were exactly the same.

In your reply you say

This is not a common error on this hardware.

I have noticed that since I bought my box, it has been remarkably slow. Slow loading pretty much anything, slow updating, slow downloading updates/apps, slow to login after entering my username and password, etc. etc. etc. I assumed that this was just because the pioneer freedombox doesn’t scream “Killer-Tech-Specs”, but now, it makes me wonder if I have faulty hardware. Is the freedombox relatively slow for everyone? Is this the default behavior? Or might I have some defective hardware? I’m using a class 10 UHS-II mini sd card that supposedly clocks ate 180mbps/read and 90mbps/write. So I dont think it is my storage medium that is causing the slowness. Furthermore, the same SD card works very fast on a raspberry pi. Any Ideas? thoughts?

Hi @Danrancan

[ Disclaimer: this answer might not be relevant to the original issue, but may help fix related ones. ]

I had a similar issue on Raspi2 with an earlier version of FB (20.18 IIRC), but never did the log file digging to find out the root cause as you did. For me the error happened when setting up a user account but since everything seemed to work fine I ignored it for the time being.

I am not using Samba at all, but at some point I was having trouble authenticating with the user account and wanted to reset it. Luckily there was this FAQ:

Since I was still able to SSH into my FB, using the provided script to reset the initial password worked perfectly fine.


On my FreedomBox Pioneer, setting a Samba password takes less than a second. I’m using a stable image, the slowness may be related to using the testing image or newer kernel. Did you check the cpu usage?