Cockpit setup SATA drive - user not authorized

I have just bought a new pioneer box with a hard drive enclosure and plugged it in last night.

The only thing I have done is connect it to the internet (an ADSL router) and set up the main username and password. I left it overnight to install any updates etc.

Now I want to set up the hard disk. My idea was to set it up so that all important user data is installed on this disk. The disk has one 200GiB partition that is currently unformatted. I thought I would try to use btrfs since this is what the main freedombox system seems to use.

I have two main problems:

  1. btrfs is not available in the drop down list of filesystem types

  2. When I go to the storage section and try to format it I get the error message “Not authorized to perform operation”

I don’t know if it is related, but in the main cockpit screen it shows in the logs an error:

“Error loading modules: Error opening directory… udisksd”

I tried restarting the freedombox but this does not fix it. My user is in the admin group. Freedombox version 20.12.1.

I also recently connected an HDD to the Freedombox and had the same problem you describe with the software cockpit.Although I don’t know if it is correct, my solution was to create a new account in cockpit.

To do this, go to the cockpit interface (Accounts> Create New account)

After you have done this you have to check “Server Administrator” and then login with the already created account.

Formatting, Partitioning etc are now possible.

Thanks for the help. I set a password for the fbx user and it worked.

Do you know how to move the root partition to the SATA drive (with just /boot on the SD card)? I have done this sort of thing before on a normal PC with grub, but I don’t know how to update the bootloader on the Pioneer / Lime2.