Clean install and diagnostics - apps "currently not available in your distribution" 22.5

I have a notebook with a fresh install of Ubuntu 22.04.1 LTS and ran freedombox installation procedures for version 22.5. Everything appeared to run successfully.

The first app I wanted to install was TT-RSS. It installed fine and is confirmed working.

Here is where it gets weird.

All the other apps I’m clicking - calibre, tor, samba, wireguard, and a few others I was clicking display the message: “This application is currently not available in your distribution.” in a yellow text box on the install page and the install button is inactive.
Presumably they all do, although I did not click on each page to verify. I didn’t see any that were installable.

Perhaps even more surprisingly, diagnostics all pass except these two:
Using DNSSEC on IPv4
Using DNSSEC on IPv6

Any ideas what it could be? I’m wondering if something happened between installing TT-RSS and now, but no other actions were taken on the notebook.

Freedombox is meant to be run on Debian, not Ubuntu. Currently, FreedomBox works in Debian Stable (Bullseye), Testing (Bookworm), and Unstable (Sid). Ubuntu may have different repositories configured, with different package versions than what Freedombox is using.

Did you install only the console environment?
Once freedombox is installed, one is not expected to log in directly to the computer anymore.

Ubuntu 22.04 is based on bullseye, versions should be aligned, so this may not be the problem. That said, freedombox is mostly used on Debian, little experience on Ubuntu.

Why did you install Ubuntu rather than Debian?

Hmm, I’m not so sure. My expectation would be exactly what @ciamx has described: some stuff works, some stuff doesn’t.

A quick web search turns up this thread: repository - is it possible to use Debian repositories in Ubuntu? - Ask Ubuntu

The consensus is trying to use Debian repositories on Ubuntu will break stuff.

" Ubuntu is really “source code derived”, but since Ubuntu and Debian use slightly different compilers, kernels, and library versions, installing Debian packages on Ubuntu can result in a lot of weird behaviors (crashes, corruption, etc). "

" If you tried installing a package from debian unstable, it might work, but there should already be an ubuntu equivalent that you should use instead. If you tried using packages from any of the older debian releases, you would be getting old versions and would run into dependency errors that would either stop you from installing or break your official ubuntu packages. "

" is possible but not recommended it can cause your system to become unstable. "

If you want to keep the Ubuntu installation up, you might have better luck if you spin up a Debian 11 virtual machine and install FreedomBox inside of that.

I was not suggesting to use Debian repositories on Ubuntu, I agree that one should not do that (it can work for specific things but not in general).

I thought that @ciamx was only using the Ubuntu repo, i.e. using freedombox from Ubuntu repo to install apps from Ubuntu repo. If so, the versions should normally be well aligned. Or do you mean that the version of plinth in Ubuntu repo would look at Debian repo? If so, that is clearly wrong.

Yes, my understanding is that Freedombox depends on Debian repos for certain packages or libraries.

cat /etc/apt/sources.list.d/freedombox2.list
# This file is managed by FreedomBox, do not edit.
# Allow carefully selected updates to 'freedombox' from backports.

deb bullseye-backports main
deb-src bullseye-backports main

I think certain things not working if this resource is not available makes sense.

Honestly, the fact that Freedombox can be installed on an Ubuntu box in the first place seems like a mistake–it will just lead to a half-baked experience.

I can’t see such a file in the Ubuntu package.

I don’t know about that (never tried) but for sure, people using Freedombox on Ubuntu should be ready to fix their problems by themselves.

So yes, I would recommend using Debian, but perhaps the issue was that @ciamx could not install Debian on their computer?

Thanks for the comments. I have no particular reason to use Ubuntu over Debian other than in past experience Ubuntu has had more preconfigured out of the box.

My general understanding was that under the hood on each they are basically Debian, with Ubuntu having more ‘junk’ prepackaged into the install that made it easier to use. I hadn’t had any issues in the past between Debian/Ubuntu compatibility - but it sounds like the general understanding is incorrect.

Re the earlier question - Freedombox was installed through the CLI commands, and the apps were installed (TT-RSS) from the Freedombox interface.

Since there’s nothing else on that computer, it won’t be hard to run to Debian instead.